Can't remove orphaned devices from Kmix / Phonon & Yast2 Sound

There are a few video and audio devices (such as an USB sound card and a TV tuner) which still show in some parts of the system although I removed them months ago and restarted many times since. Some are devices I no longer have in my computer, others are duplicate entries of devices I already have that work. This namely happens in Kmix / Phonon where the Device Preference list shows removed devices in gray, and in Yast - Sound where I see my wireless headphones listed two times and only one entry works (probably due to relocating the nano-receiver to another USB port). The YaST2 Sound menu has a button to delete the device, but instead of deleting it just labels it as “Not configured” rather than giving it an index. They don’t harm anything, but I prefer to have my system set up properly.

Any idea how to get rid of the grayed out devices?

For the Logitech Device shown in YaST / Hardware / Sound, you need to delete the one that is configured and then Configure the one that is not configured. This can happen if the IRQ or port assignments changed for some reason I have found. The PC BIOS can do that if reset (New BIOS Update) or a device was added or removed. Make sure your default sound device you use is the default:

Next, when you go into the Phonon, you answer Yes, to remove or forget about the past configuration or sound card. Unless you know what you are doing, there is no reason to keep a configuration determined to no longer exist. Make sure the sound card you are using has a proper sound profile selected and a sound device you do not use should have the profile of off.


Thank You,

Thanks for the reply. Sadly I still don’t understand what to do exactly, and my problem seems a little different than that.

I did try to delete the bad device in YaST2 Sound. But instead of removing it, it only sets the Index field to “Not configured” instead of a number (first screenshot in your post).

About being prompted to forget: If I restart ALSA, KDE does prompt me to “Permanently forget about these devices”. I click Yes, but if I look in Phonon again nothing changed and they are still there.

Lastly, I did look at the menu in the second screenshot of your post. But the orphaned devices are not listed there (under the “Sound Card” drop-down list) so there’s no need to set their profile to Off. They only appear in the Device Preference tab, left of the Audio Hardware Setup tab which you have selected.

Trust me if in YaST / Hardware / Sound, an identical device shows up twice, once configured and once un-configured, you need to delete the the configured one and edit the un-configured one. You must end up with all configured devices there when done and identical dual entries should not exist. Your default sound device should be index 0, on the top. As for the PulseAudio sound profile, you must make the profile of OFF for any sound device you do not use for sound. When you allow devices to be removed, you must restart KDE to see the results of that change. Look again at the examples shown.

Thank You,

Ah-hah! I managed to remove the duplicate device in YaST2 Sound that way. I unplugged the USB nano-receiver for my headphones, then one entry disappeared and I could delete the other. Once I plugged it back in it appeared in the list again, this time only once. I re-configured all audio devices to be safe and everything seems fine now. Thanks jdmcdaniel3.

Only problem left in YaST2 Sound is that two entries have their names inverted. If you look at the second screenshot in my first post, I have one called “ATI Technologies Inc” and “GA-EP45-DS5 Motherboard”. If I select the ATI one and choose “Play test sound” the sound plays in the speakers connected to the motherboard. Would be nice if I could fix this too, but that’s way less severe and I can live with it (under Phonon they’re labeled correctly).

In Phonon the problem still exists after restarting, and looks like the first screenshot in my first post (but this is likely a separate issue). Once again, in the Audio Hardware Setup tab they are ok, just not in the Device Preference tab. When I fixed the YaST2 - Hardware - Sound problem I was prompted numerous times to permanently forget some devices, and each time I clicked yes… yet they’re still there. How do I solve the Phonon entries too?

Let me say that in the Phonon Device List, every possible audio Output device will be shown. Devices that can not be used will be grayed out. When a single Audio device has more than one output, only the one for the Audio Profile you selected will be dark. The ones in dark should be moved to the top of the list to be the default and the rest do not matter. In the list you show, only the top and bottom ones are considered usable by Phonon while others exist, but may have a profile of Off or one of several devices on the same sound device where you can only use the one for the Audio Profile you selected. I normally move all that work to the top as number 1 or number 1 & 2 perhaps, but only #1 is used by default. Other audio applications could select between devices show to work in this list.

Thank You,

Ah, I understand in that case. I know grayed out devices are unusable, but I still wanted to clean the list of what shouldn’t be there. I thought the grayed ones are also due to orphaned devices being misinterpreted (only one of them is a device legitimately set to Profile - Off). Looking throughout the settings, I still don’t understand why my wireless headphones show two times, as well as my motherboard audio card with “Internal Audio Analog Stereo” then “Internal Audio Analog Stereo 5.1” at the same time. Worst case is that, under Video Recording I also see a TV tuner which I permanently unplugged months ago… so that one is clearly an orphaned entry.

Since some are likely very downdated, I’d still like to remove all entries which aren’t there because of an existing device or a profile being set to Off. If not possible though, I guess I can live with it. Perhaps I can manually edit some file or cache?

As I look at my list, there are seven entries there and only one is dark. Four belong to my sound card, one to the audio on my Video Card, one for my built-in audio to the motherboard plus one called Dummy Output, the default when you don’t have any sound devices found I guess.

Thank You,

Yeah, but it still doesn’t sound right to me. If someone knows how to safely attempt removing them, I’m still curious to find out. If not I’ll live with it like that since it doesn’t harm anything else.

The only thing I would worry about is if the sound device I want to use works or not. If it does work, I don’t care how much useless info might be displayed there.

Thank You,

They do work well, so no problems on that side… otherwise it would be more concerning.

So I am not sure in this exchange if I helped you much or not. I hope I did. But, what I also care about is that openSUSE is working for you and in that I hope we were successful.

Thank You for using openSUSE,

It did help with the YaST2 Sound at least, and overall it is working well. Thank you :slight_smile: Still looking to remove the bad entries in Phonon otherwise, if anyone else knows perhaps.