Can't Print from Firefox over network

My wife’s laptop (Running 11.0) is able to print through our printer attached to our desktop computer which is shared through SAMBA via CUPS.

She is able to print in all apps (OpenOffice, Thunderbird, Konqueror, etc.) except for Firefox (3.0). When printing in Firefox it looks like everything worked, but nothing prints and nothing shows up in the CUPS print que.

I looked at the about:config page in firefox, and saw that the lpr command is being used for printing. When I type “lpr” in a console, nothing happens (the console just freezes with no message and I have to close it). The same thing happens if I type “lp”.

Any ideas as to how to fix this, and why it only affects Firefox would be greatly appreciated. I followed the Firefox support page’s advice on resetting the print.print line in about:config and restarting, but it didn’t help. I’m also sure that I’m not printing to file, and am out of ideas…

Is this running FF on the remote machine?, if not try it.

Also, double check the default settings in the print window when FF throws it up, it may be different than in you Office apps.

Thanks for the quick response.

Yes, it’s Firefox on the remote machine (laptop) that won’t print. Firefox on the desktop (to which the printer is physically connected) prints just fine (but the lp and lpr commands seem to work fine on the desktop computer also).

The settings appear to be O.K. in the print dialog box. Firefox uses it’s own print dialog box, so it’s tough to directly compare to other apps.

I thinking it has to do with the lpr command (and lp for that matter) not working…

But what I mean is try running FF on the desktop remotely from your Laptop. I use ssh to do this. You can start any application on your desktop from your laptop. Open a terminal in your laptop and ssh to your desktop. Then run FF with: firefox

I don’t use samba myself, but prefer kdessh or just use fish:// to the server.

Oh.

I ssh’d in and typed “firefox”, but it says:

“Error: no display specified”

(Sorry, I haven’t used ssh, so let me know if I’m doing something wrong)

I think I figured part of it out:

Thunderbird still prints fine (and firefox and thunderbird both use the same engine from what I understand).

In Thunderbird’s about:config the printer is listed as “CUPS/Pixma”, but in Firefox it’s listed as just “Pixma”.

I tried to change it to “CUPS/Pixma” in Firefox, but it gets reset back to “Pixma” when I do the print command. Does anybody know how to make this change “stick”?

I use kssh from the kde3 community repo

Index of /repositories/KDE:/Community/openSUSE_11.1

I don’t know though what desktop you use?

I do use KDE.

I got it working again! In desperation, I re-setup the printer again using a different name in CUPS (Pixma2). I used all the same settings, but it worked! I can now print from every program I’ve tried, including firefox.

I have no idea why it stopped working or why installing the exact same printer under a different name worked. Maybe firefox got it’s internal settings for the “old” name screwed up, so changing the printer name helped?

Thank you for all your help caf4926. ssh seems pretty handy, so I’m going to look into it more.

That’s great news. Well done.

FYI. For simple file management ssh is great. In kde I actually use fish eg:

fish://xxxx@192.168.0.2/home

xxxx= the username on the server
192.168.0.2 = LAN IP of the Server

you might want to consider reading
http://susewiki.org/index.php?title=Public_Key_Authentication_with_SSH

==========================

kssh form the community kde repo works a treat, even in kde4.

Here is a snapshot of it with those settings
http://thumbnails17.imagebam.com/3287/9f75ab32865419.gif](http://www.imagebam.com/image/9f75ab32865419/)

Just connect and it opens a terminal connected to the server address.

Type: firefox
and firefox starts on your laptop (remote machine), but it’s the firefox application from the server.
I use this connection sometimes when the wife is hogging the desktop (server) - just to run apps. Like, sometimes azureus. The files still download to the server locations, the application is running and controlled in the remote machine.

That’s pretty slick. I’ll definitely check it out.

Thanks again.

Since I reinstalled the printer (see above), it has again stopped printing in firefox twice. The only way I’ve found to resolve the issue is to reinstall the printer via CUPS. When it happens, I’m able to print from every other program I try, including Thunderbird. Firefox is the only program affected.

Does anybody have a clue why this is happening? It seems to happen at random.

Could it be worth trying this. Re-name your hidden .mozilla folder in /home/*user/.
to .mozilla_old

Now when you start FF it will be vanilla.
Try using FF now

(I was just curious to see if there could be some crud in the settings in your old folder throwing a spanner in your attempts.)

Thanks for the suggestion. I’ll try it if/when it stops working again.