Can't play WMA files in Opensuse 13.2

Hi,
I found out I have some troubles with playing WMA files in Opensuse 13.2.
I tried to be as much sure as I could into installing all gstreamer_0.10 packages, and more of it, all to be from packman repository (yes, I have gstreamer_0.10-plugins-base, gstreamer_0.10-plugins-bad, gstreamer_0.10-plugins-good, gstreamer_0.10-plugins-good-extra, gstreamer_0.10-plugins-ffmpeg, gstreamer_0.10-plugins-ugly; same for the versions 1.1 of gstream).
I tried with Clementine (1.1.1 version, from previous Opensuse, for personal reasons), and it goes with error like <<Your GStreamer installation is missing a plug-in.>>

Audacious and Rhythmbox also can’t play WMAs.

VLC, on the other hand, can !

Well, this is not very important for me (I don’t like this Microsoft format, and anyway I have very little amount of WMA files; I was successful in converting them to mp3 with WinFF, so no big deal), but still … what else do I need in order to be able to play WMA files ?
I remember from Opensuse 13.1 (or was it 13.0 ?) when I was able to do it, but unfortunatelly I can’t remember anything else, besides all those gstreamer packages that I needs to be installed.

WMA is just a container format, and doesn’t say anything about the actual codec that’s used/needed.
Anyway, check that the following packages are installed (from Packman and it should play in any case:

  • gstreamer-0_10-plugins-bad-orig-addon
  • gstreamer-0_10-plugins-ugly-orig-addon
  • gstreamer-0_10-ffmpeg

And make sure all your gstreamer-0_10 packages come from Packman. Maybe do a “full repository vendor change update” to Packman to be certain:
https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change

Audacious and Rhythmbox also can’t play WMAs.

For audacious you need audacious-plugins-extra, Rhythmbox uses gstreamer 1.x, so you need the appropriate codecs for that:

  • gstreamer-plugins-bad-orig-addon
  • gstreamer-plugins-ugly-orig-addon
  • gstreamer-plugins-libav

Thanks a lot.

The packages -orig-addon were not installed.
After installing them (for gstreamer-0.10 and gstreamer-1
) all players are now able to play WMAs.

So, my problem is solved.