Can't play videos in Banshee or Totem

I’ve tried to play a number of video formats in the two players but apparently it wants various non-free codecs? I don’t suppose the ones for 11.3 will install?

Add the packman repo for 11.4:-

Index of /suse/openSUSE_11.4/Essentials/

well, I added the repo and installed everything I could think of and banshee and totem still don’t play. I tried installing vlc and that ends up pegging the cpu and more or less locking up.

since I was mildly scolded for not including this info elsewhere :slight_smile: I am including it here.
the host is OSX 10.6.6
the guest is openSUSE 11.4 RC2 Gnome from the live cd
VirtualBox 4.0.4
the VBox 4.0.4 components that were pre-installed after I installed it and updated it once.

some further info on VLC 1.1.7 from the packman repos. I played an .avi file and that was ok although it used nearly 50% of the CPU. Then I tried playing a .flv file and the CPU pegged at 100% and it completely filled up 100% of the memory. Memory leak perhaps?

I still can’t get Banshee or Totem to play the video portion of a movie file, although the sound works, usually.

Have you installed win32 lib?

I hadn’t but I just did and it didn’t help. It’s odd, for every video format I’ve tried to play I get a message I need such and such codec to play a file and I know some of them are installed.

I want for you to open a terminal

su
# zypper lr -d

here…
linux-vsm5:/home/louis # zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±------------------±---------------------------±--------±--------±---------±-------±----------------------------------------------------------------±-------
1 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/Essentials/ |
2 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /factory-snapshot/repo/debug |
3 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
4 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /factory-snapshot/repo/non-oss |
5 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /factory-snapshot/repo/oss |
6 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /factory-snapshot/repo/source |
7 | repo-update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |

Try to run in your terminal

Banshee

What kinds of video do you try to run?

I tried both as a user and root and get this…
linux-vsm5:/home/louis # banshee
If ‘banshee’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf banshee

both banshee and Banshee

 Banshee

Not banshee

so far I’ve tried .flv, .avi. .wmv, .mov, .mp4

Try ro install vlc or smplayer.

yes I know, I tried banshee after Banshee wouldn’t work

I have VLC 1.1.7 installed and although it played most things, it also ended up using up all my CPU and Memory then locked up everything.

Read this MOV Codec at Suse Software Informer

thanks. that’s all well and good but it doesn’t explain why Totem nor Banshee iwon’t play .flv or .avi or wmv files.

or why Banshee won’t start from the terminal, etc.

I want for you to go to your terminal and write

su
# zypper search Banshee