Can't play MP3-files


I can’t play MP3 files. I followed this guide:
Restricted formats - openSUSE

That didn’t help, so I went with the 10 steps to check the multimedia. The output is here:

jacob@linux-h7fo:~> LC_ALL=C zypper ve

Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.
jacob@linux-h7fo:~> rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
jacob@linux-h7fo:~> rpm --verify --query --all 'libav*' 'libpostproc*' 'libswscale*'
jacob@linux-h7fo:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' libxine1 libxine1-codecs
libxine1- -> openSUSE                                                                                     
package libxine1-codecs is not installed                                                                                     
jacob@linux-h7fo:~> rpm --verify --query --all '*xine*'                                                                      
jacob@linux-h7fo:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly                                  
package gstreamer-0_10-ffmpeg is not installed                                                                                                                                                      
package gstreamer-0_10-fluendo-mp3 is not installed                                                                                                                                                 
package gstreamer-0_10-fluendo-mpegdemux is not installed                                                                                                                                           
package gstreamer-0_10-fluendo-mpegmux is not installed
package gstreamer-0_10-plugins-bad is not installed
gstreamer-0_10-plugins-base-0.10.24-2.4-x86_64 -> openSUSE
package gstreamer-0_10-plugins-good is not installed
package gstreamer-0_10-plugins-good-extra is not installed
package gstreamer-0_10-plugins-ugly is not installed
jacob@linux-h7fo:~> rpm --verify --query --all '*gst*'
jacob@linux-h7fo:~> rpm --verify MPlayer
package MPlayer is not installed
jacob@linux-h7fo:~> rpm --verify --query --all '*vlc*'
jacob@linux-h7fo:~> rpm --verify w32codec-all
package w32codec-all is not installed
jacob@linux-h7fo:~> rpm --verify w64codec-all
package w64codec-all is not installed

I’m using KDE on a fresh install of OpenSUSE 11.2
I notice there are some problems with that list, not all the output is as it should be according to the guide I followed. But I’m not sure how to proceed.


On our forum we have a how to / faq area for new users. In fact, most forums have such an area. In our case it is here: New User How To/FAQ (read only) - openSUSE Forums

Now if you look in that area you will see this written by caf4926 (although I posted it for them): Multi-media and Restricted Format Installation Guide - openSUSE Forums

Note, I always recommend one keep nominally enabled 4 and ONLY 4 software repositories. those are the OFFICIAL 3 repositories: OSS, Non-OSS, and Update, and then one and ONLY one 3rd party repository which is Packman. Just those 4. No others None. Not one.

Once those 4 are established one can via YaST > Software > Software Management install libffmpeg0 and ffmpeg packaged by Packman, which provide all sorts of codecs. If one went and installed apps from the Videolan repository (other than libdvdcss) that will possibly cause problems and those videolan packaged apps should be replaced with packman packaged versions.

This is actually incredibly easy, and takes minutes after a fresh install. But one needs to know what to do, and not go off on a different approach. There is limited to no tolerance for adopting the wrong approach.

You should follow this
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Make sure VideoLan and or libdvdcss repo/s are removed!
(Not the actual package libdvdcss, you can leave that)

Make sure you have the listed packages
And try doing this

If you can’t get back to me

I don’t really understand. I found that guide on this page, I thought it was the right one. Sorry about that.

I’m now following this guide:

Multi-media and Restricted Format Installation Guide - openSUSE Forums

I’ve made sure to follow the OpenSUSE 11.2 part of it. I’ve reduced my repository list to those 4 oldcpu recommends, but I can’t see packman when I sort by repository:

Here’s the repo list to confirm that packman is there…
OpenSUSE :: Repo list picture by JacobCollstrup - Photobucket
Here’s what I see in the software manager:
OpenSUSE :: sorted list without packman picture by JacobCollstrup - Photobucket

I have installed libdvdcss and removed the vlc repo after that. I didn’t screw by doing this in another order did I?


Note, you have to “enable” packman. Its not enabled in the image you provided.

That earns me a ‘stupid point’ doesn’t it? :stuck_out_tongue:

Sorry about that…I feel a little bit silly now.


lol ! I must have a zillion of those points myself that I have collected over the years. :slight_smile:

Ok I tried doing that after enabling packman. Somehow I managed to screw up. I think. I’m not sure. I just pressed the first line I saw like that. The system repo was highlighted in the list. It wanted to update somethings, to which I said ‘ok’ thinking it was supposed to do that. It also told me I was removing the HDA device and ALSA. It asked me what I wanted KDE to, of the following: Completely forget about it: yes/no or manage the device. I answered ‘no’ to that. After that the sound icon was gone from the system tray, in the buttom right corner.

After a few minutes I found out I could switch back, I did so. It didn’t change anything. I then highlighted packman repo and pressed ‘switch system packages to the versions in this repository (packman)’. I think the error I did also wanted to make the same switch. But I’m not sure. I forgot to take screenshots in the confusion.

I’m listening to MP3s through amarok as I type this, so I’m not sure I did anything wrong or if I did the right thing another way.



If you do something like that, just quit Yast and abandon any proposed changes
Restart Yast and start again.

But it sounds like you are OK;)

I need to write that down somewhere !! :stuck_out_tongue: I was seriously looking for a hole to get out of that loop !!

Thanks for the help guys !!