Can't permanently rename or hide selected devices in Dolphin's Places panel

According to Kinfocenter:

KDE Plasma 5.8.7
KDE Frameworks 5.32.0
Qt version 5.6.2

Dolphin version 17.04.2

Problem: inconsistent Places panel configuration.

Description: it is possible to rename and/or hide partitions and shares in the devices section of the Places panel (F9), however if I close and reopen Dolphin, all devices are shown again, with the original names, f.e.,

/home/shares/files on

instead of
Files on Server 1*.

Device entries are renamed by right-clicking the entry and editing it’s label and/or ticking the Hide checkbox.

Right-clicking on the Devices title, the show all entries checkbox is unselected. If selected, then not only all Devices section entries are shown, but also the previously hidden panel entries, Recently saved and Search for, are shown back.

If I hide some entries, close and open Dolphin, sometimes all entries come back, other times all mountable entries are shown (i.e. windows 10 special partition is not), and after trying a few times now while testing to write this post, the hidden entries stay hidden but the entries shown revert to their original names.

Is there a Dolphin configuration file where these entries can be renamed/hidden/shown directly, since the GUI interface seems defective?


The dolphin configuration file is ~/.config/dolphinrc, but some of the configuration settings are ‘embedded’ in ‘State=…’ strings. Maybe someone else can clarify further.

Thanks, Deano. I think these names currently are not saved anywhere. At least, after changing them there’s no timestamp change in any of the files in .config nor .kde4.

~/.config/dolphinrc is changed if you, f.e., enable/disable another panel and such. To test this I diffed two files:

dolphinrc1 with original device names, no information panel
dolphinrc2 after renaming a few devices, enabling and disabling the info panel (so it’s timestamp is newer).

And diff -q dolphinrc1 dolphinrc2 show no differences.

So perhaps it’s a not-implemented-yet feature…

It’s interesting to note that in the original names, /home/shares/files is the path on the server, in the client machine these nfs shares are mounted to different directories (e.g., /home/<user>/shares/files). So perhaps Dolphin is extracting them directly from fstab.

Now I’m with you. I thought you were referring to ‘Places’ where the entries can be renamed persistently. I’ve never tried editing the titles given to the ‘Devices’ entries though. The entries are located in ~/.local/share/user-places.xbel, but as you mention the title for the devices (even if editing user-places.xbel directly) do not take effect. For example, I changed my ‘16.0 GiB Hard Disk’ title to ‘Test’, but the displayed name remains the same.

The hidden entries problem may possibly relate to this old, uncommented on, bug:

“Senior moment” … forgot to also say that with regard to renaming devices, in Dolphin 17.12.0 (and possibly earlier), the option to rename a device has been removed from the context menu.

Dolphin 17.04.2 on the left, 17.12.0 on the right.

Indeed, and that’s because it never worked, it never was supported to rename devices with dolphin at all.

That device names were editable in dolphin’s “Places” pane was a bug that was fixed in 17.08.0:

Thanks for clarifying this.

A small follow-up:

After restarting Dolphin only one device is hidden, no matter how many where selected. You have to exit and restart dolphin, select another device to hide, rinse and repeat.

Well, there has been serious reworks in this regards in KDE Frameworks(to be in 5.42.0 IANM) and dolphin (git master branch) recently, but that’s not something that can be backported to 42.3 I’m afraid…

As I wrote in comment #6 (perhaps you missed it) it looks like this old bug: