Can't open Yast "Boot Loader" menu

The error I get reads…

Details : Augeas parsing/serializing error: Get did not match entire input at /usr/share/augeas/lenses/dist/sysconfig.aug:63.12-.71:

Caller: /usr/lib64/ruby/gems/2.1.0/gems/cfa-0.3.1/lib/cfa/augeaus_parser.rb:236:in 'report_error'

My only recent activity has been installing GeckoLinux on a different partition on my hard drive and letting it set the Grub boot menu into the MBR. Any help would be appreciated.

Then, Gecko Linux has taken control. I know it’s an openSUSE derivate, but I’d ask the dev(s) over there what’s going on. We here simply can’t support these spin-offs since it’s virtually impossible to trace what the difference is with “ordinary” openSUSE releases.

I don’t understand how their (Gecko Linux) could affect my Leap 42.2 installation when it’s partition was not mounted. Does that mean I could have a similar problem if I install Debian alongside Leap?

Because you allowed Gecko linux to control the MBR, and the BIOS starts booting at the MBR. So you should get a boot menu from Gecko. Maybe try running yast bootloader from Gecko.

Thanks, that’s a good explanation that I can understand. In the meantime I solved my problem (changing my default boot) by invoking…

grub2-install /dev/sda

Leap’s YaST is still not happy, but I am.