Can't open respositories or manage software from YaST

When I do “YaST>software>Software Repositories” or YaST>Software>Software Management" I get the following message:
System Management is locked by the application with PID 7917 (/usr/sbin/packagekitd)
Close this application before trying again.

I’m willing to end the app if I knew how. looked for that PID in GnomeMonitor but never found it there. I thought I might kill it there. :frowning:

See the updater applet in the systray - right click and configure
Do not start at boot and quit it.

Try Yast again

There IS NO sysupdate applet present in the system tray!

Thank you for your timely response! I I changed nothing but it works now anyway…

In a su terminal do

ps ux

you will see a list of applications, look for the one in question and it’s PID number then do Eg:

kill -9 3216

this is an example PID

killall packagekit can work as well

A little more background, may add flesh to the previous answers:

  1. If any process is accessing the package database, other processes are locked out from that database, to avoid problems with concurrent changes.
  2. When you start up the GUI (whichever one you are using), traditionally the system does a check for package updates. If you wait for roughly five minutes (or until a ‘software updates are available’ message pops up), this process of checking will have finished and this problem will not occur. This is the easiest ‘solution’ and the one least prone to side effects, but when you want to do it now…
  3. Finding a task when you know the pid or the task name is most easily done by ‘ps -ef | grep -i xxxx’ where xxxx is a fragment of the taskname, or the pid (in a terminal window).
  4. You can then either use the ‘kill’ or the ‘killall’ method; killall is quite nice, provided you don’t do something like specify a string which several tasks match. Killing off tasks is a bit brutal and should only be done when you are sure which tasks you are killing!

Thank you so much. Killall packagekitd worked like a champ!