Can't no boot at all -- no space left on device


I tried this morning to install the android sdk it failed badly: the system freezed for the first never seen before in Linux (all the decorations of the windows disappeared and the keyboard was unresponsive, hard disk led set) → I did a hard reboot.

Now, the system is completly corrupted, I could sometimes log in but I got straight error message splash indicating Kwin failed and after that the system backed to be unresponsive.

I tried once to go in recovery mode, it worked but impossible to repair the btrfs root device :{

I tried to boot on install dvd and choosed “rescue system” but impossible to use a god ****ed command to check the corrupted filesystem

Now, each time I boot I got messages telling that “no space left on device” for each service the system is expected to launch.

I read some threads about such issues but I’m not completly sure it fits my situation.

I have not backed up some system settings and don’t want to clean install 13.2 on this computer.

Anyone could tell me how I could repair the btrfs root partition (I guess is all about partition corruption) it was working all good at 6 am without any bug.

Apparently your partition is full, not corrupted, so just delete something.
A good idea would probably be to remove some snapshots with “yast snapper” or snapper directly, you might also have to rebalance the filesystem.
See also:

If you still want to run fsck, add “rd.break” to the boot options, that will stop the boot process before the root partition is mounted read/write.
Unmount /sysroot and run btrfsck.

Well done !!

I find where all the files (generated) where stored, I started a ‘rm -Rf *’ in this folder ten minutes ago and it is not yet finished… the df -h indicated 77% of use I just learned to don’t trust this information ^^

I will NEVER try no more to install the android sdk, finish, dot end !

Thanks a lot !!

All is ok now, you were right at 120% ^^

I learn every day how handle such a powerfull OS as Linux is… and someday I feel like a dumb with my reactions/interpretations…