Can't mount NFS drives

After the upgrade to 15.3 I can’t mount NFS drives. They appear in /etc/fstab as


Synology:/volume1/NetBackup                /nfs                    nfs    defaults                      0  0
Synology:/volume1/photo                    /nfs2                   nfs    defaults                      0  0
Synology:/volume1/music                    /nfsmusic               nfs    defaults                      0  0

but I can’t mount them in Dolphin or in Konsole:

sudo mount -a 
mount.nfs: access denied by server while mounting Synology:/volume1/NetBackup 
mount.nfs: access denied by server while mounting Synology:/volume1/photo 
mount.nfs: access denied by server while mounting Synology:/volume1/music

I see many others with similar issues, but the solutions seem to leave out too much or are too cryptic for me, or don’t really seem to apply. Thanks for any help!

Try mounting manually with verbosity like this…

sudo mount -t nfs -vvvv  Synology:/volume1/music/mnt  /nfsmusic

…and observe/capture the output. That should show what the underlying issue is. (It may well be a NFS protocol version issue.)

This is what I get:

sudo mount -t nfs -vvvv  Synology:/volume1/music/mnt  /nfsmusic 
[sudo] password for root:  
mount.nfs: timeout set for Sun Oct 24 21:38:11 2021 
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.18,clientaddr=192.168.1.6' 
mount.nfs: mount(2): Permission denied 
mount.nfs: access denied by server while mounting Synology:/volume1/music/mnt

And by the way, the specified timeout was a minute or so after running the command.
In Yast, the NFS client version is set to “any,” and changing that to “force v4.2” had no effect on the result, though I didn’t try rebooting, so not sure how that may have affected the result.

Can you mount successfully using NFSv3?

mount -t nfs -o nfsvers=3 Synology:/volume1/music/mnt  /nfsmusic

Sigh, that doesn’t work either …

sudo mount -t nfs -o nfsvers=3 Synology:/volume1/music/mnt  /nfsmusic 
[sudo] password for root:  
Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /usr/lib/systemd/system/rpc-statd.service. 
mount.nfs: access denied by server while mounting Synology:/volume1/music/mnt

Just in case this is pertinent to your situation (Synology NFS server permissions)…
https://community.synology.com/enu/forum/3/post/139546

Interesting. Unfortunately, Yast does not allow the “/” in the IP when configuring the hostname.

The path should have been “Synology:/volume1/music” (matching your synology share). The “/mnt” at the end was a mistake. Please run the amended mount commands again.

That gave the same result.
I suspect that the problem is related to the hardware and boot sequence. The computer is a Dell XPS something with a 256GB mSATA SSD. At first it was great to have the machine boot up quickly, but now it is as slow as anything, perhaps due to establishing network connections. At any rate, I could not get the original installation to work on the SSD without disconnecting the hard drive until after completing the installation. Probably I should have done the same thing when doing the upgrade to 15.3 from DVD. I may just have to disable the SSD and do a clean install, but I’m not looking forward to that :frowning:

Just a shot in the dark: Are connected to your LAN with the same device as always? I have had a similar issue: I’m normally using wlan0 which always gets the same IP address from DHCP. For upgrade I used eth0 to avoid interruptions. eth0 gets a different (fixed) IP address. The hostname is the same. After upgrade (to 15.2) I couldn’t mount nfs while connected via eth0. IIRC it was some permission issue, too. Changing back to wlan0 solved it. I assume the different IP address with identical hostname triggered a security measure but I never got round investigating this further. Maybe you have a similar issue?
I may open a thread with my specific question when there is more time during the Winter.

Using Network Manager, it doesn’t appear that I can change that, it is set as “p3p1” and Newwork Settings in Yast won’t let me mess with that. I do believe that has been unchanged.

I assume you would know. I have physically changed my connection (plugged in the cable to use ethernet rather than WLAN). If you haven’t done that my guess was wrong.

I don’t think that’s my problem, a MythTV box on the network is still able to access the NAS without modification of the IP address.

Synology NAS model?

Synology references:

It’s a DS413j. Thanks for posting the references, that was the key. I had done the appropriate steps before, but since I was focusing on getting access from the MythTV box for the photos, I apparently neglected to set a static IP for the desktop on the router, and that IP had apparently changed. After going through the steps all over again, I discovered the problem was with the NFS permissions on the NAS not granting access to the desktop with the changed IP. Oh how embarrassing!!! I’m so sorry to have wasted your time on this because of my stupid error.

Guess we can mark this as solved, though I don’t see how to do that …

No worries…glad to read that it is now working as expected.

Guess we can mark this as solved, though I don’t see how to do that …

We don’t mark as solved explicitly here, although you can change the thread title in your reply to reflect that if desired. Anyway, glad to have been of guidance.