Can't mix multiple audio sources when using S/PDIF

Hi all,

I’m using optical S/PDIF output, called “HDA Intel, AD198x Digital (IEC958 (S/PDIF) Digital Audio Output)” in Phonon preferences. Sounds works just fine – except I can’t use multiple audio sources simultaneously: for example Amarok+YouTube is a no-no. Only the first audio source plays, so I have to close Amarok in order to listen to any Flash videos. I had this problem already with openSUSE 11.2, but couldn’t figure it out (using 11.3 now).

I just recently got a hunch that it might have something to do with mixing and the S/PDIF, and I tried using analog output (“HDA Intel (AD198x Analog)”). Lo and behold, it works! Amarok+Flash that is, VLC+Flash still doesn’t. I still consider this a major leap forward.

However, I’d like to keep using my optical output. Any ideas how to enable the mixing of multiple audio sources with S/PDIF? And how is the analog output differing from the optical? I quite don’t understand why they behave so differently.

In case anyone is looking for a solution to the same problem: I followed instructions in this post, and mixing finally works fine.