Can't login to my account, only as root

I have a dual-boot system with windows xp and suse 11.2. The last time tried to enter to suse i couldn’t login to my account ,only as root. I tried to solve this through suse dvd repair option andit detected a problem in grub. i repaired it but still nothing.Also the /home partition exists and i can access it when i login as root.
Any thoughts?

  1. don’t log into the GUI as root. Bad mojo. All sorts of problems can happen.

See if you can log in as yourself from the command line.

Press 3 at the boot screen then boot.

log in as your self

Report result, also what desktop.

Note if by chance an errant process has filled up your PCs / , you could have these symptoms. I once had a 1TB / filled up in just over 24 hours by a bad process (and my own silliness).

Next time you login , type:

df -Th

to see how much space you have left in /home

it turns out temp folder was bigger than i thought. root directory was 100% full. everything is ok now.THANKS

By default SuSE does not empty files in /tmp. You can clean /tmp with every boot by opening the file /etc/sysconfig/cron as root and edit the line


Change the “no” to “yes” and /tmp will not bother you anymore.