Can't login to KDE4, "could not start kstartupconfig4"

Hi,

at first my system: I use 32-bit openSUSE 11.1 with the following repos:

user@machine:~> zypper lr
# | Alias                 | Name                  | Enabled | Refresh
--+-----------------------+-----------------------+---------+--------
1 | openSUSE-11.1-Non-Oss | openSUSE-11.1-Non-Oss | Yes     | Yes
2 | openSUSE-11.1-Oss     | openSUSE-11.1-Oss     | Yes     | Yes
3 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes     | Yes

All packages are up-to-date and in YaST I don’t have any blue or red packages.

The problem is easy: When I try to login to KDE4, I get the error message

Could not start kstartupconfig4. Check your installation.

KDE3.5 works fine so far.
Of course I googled the error message and tried some things that were posted. When I create a new user I CAN login, but when I move my home directory (incl. chown afterwards) it begins again.

I also tried to start kstartupconfig4 from konsole when logged in to KDE3.

user@machine:~> kstartupconfig4
kstartupconfig4: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

So I see that there has to be something wrong with Qt. Other people with this error message was helped by uninstalling “Nessus”. I don’t know what this is and I don’t think, that i have in installed. The only package coming up, when I search for “nessus” in YaST is “openvas-client”, which I don’t have installed.

I read that these commands can help you, but I don’t know what they mean:

user@machine:~> cat /etc/ld.so.conf
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/lib/Xaw3d
/usr/i386-suse-linux/lib
/usr/local/lib
/opt/kde3/lib
include /etc/ld.so.conf.d/*.conf

user@machine:~> cat /etc/ld.so.conf.d/*
/usr/lib/graphviz
/usr/lib/graphviz/sharp
/usr/lib/graphviz/java
/usr/lib/graphviz/perl
/usr/lib/graphviz/php
/usr/lib/graphviz/ocaml
/usr/lib/graphviz/python
/usr/lib/graphviz/lua
/usr/lib/graphviz/tcl
/usr/lib/graphviz/guile
/usr/lib/graphviz/ruby

Any hint what to do is appreciated.
Or is there any info that I can give you that would you diagnosing me?

Some time ago I tried this with 11.0 and there was also some discussion here: Can’t login to KDE4 - openSUSE Forums …leading to the result of a new user, which doesn’t work, I think.

Thanks (in advance) for at least reading this.

P.S. This is my PC at work, so I am at this PC only during office hours but I can login per ssh from home, but I think I can’t test the login into KDE per ssh, right?

Greetings,
KommX

I’m very sorry to reactivate this thread, especially because this is partly my own fault, because I once solved this problem and I didn’t write the solution here and now I can’t remember the solution but I have some hints for you people who are more into Linux than I am.

I just moved to a new Computer (64bit opensuse 11.1 with KDE 4.3.1 from factory) and now the problem has risen up again.

In the post above I already wrote that the problem must have something to do with QT4 libraries.

In another thread (Can’t log into KDE on F9, via nx, after recent updates? Error message about kstartupconfig4.) with the same problem it was because of nessus (a program I don’t know and I don’t think I’ve installed) and its qt libraries.

I still remember that on my machine the problem was Matlab and its qt libraries, but I can’t remember what I did on the old machine so that it worked. I did not uninstall it because I used it a lot.

Here are some outputs I hope can help you

gregory:/etc # cat /etc/ld.so.conf
/usr/X11R6/lib64/Xaw3d
/usr/X11R6/lib64
/usr/lib64/Xaw3d
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/lib/Xaw3d
/usr/x86_64-suse-linux/lib
/usr/local/lib
/opt/kde3/lib
/lib64
/lib
/usr/lib64
/usr/lib
/usr/local/lib64
/opt/kde3/lib64
include /etc/ld.so.conf.d/*.conf

machine:/home/user # cat /etc/ld.so.conf.d/*
/usr/lib64/graphviz
/usr/lib64/graphviz/sharp
/usr/lib64/graphviz/java
/usr/lib64/graphviz/perl
/usr/lib64/graphviz/php
/usr/lib64/graphviz/ocaml
/usr/lib64/graphviz/python
/usr/lib64/graphviz/lua
/usr/lib64/graphviz/tcl
/usr/lib64/graphviz/guile
/usr/lib64/graphviz/ruby

If I should provide you with more information please say so and I will do.

And I this time I promise to post the solution if I have it.
I’m very sorry but I hope you can help me.

Thanks,
KommX

Post result of this:

zypper lr -d

I’m sorry that I didn’t answer earlier, I have problems to login from ssh on the new machine:

Here are the repositories:

zypper lr -d
# | Alias                    | Name                     | Enabled | Refresh | Priority | Type   | URI                                                                                  | Service
--+--------------------------+--------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
1 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1/ |
2 | devel:tools:building     | devel:tools:building     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/      |
3 | repo-debug               | openSUSE-11.1-Debug      | No      | Yes     |  100     | NONE   | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                       |
4 | repo-non-oss             | openSUSE-11.1-Non-Oss    | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                         |
5 | repo-oss                 | openSUSE-11.1-Oss        | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                             |
6 | repo-source              | openSUSE-11.1-Source     | No      | Yes     |  100     | NONE   | http://download.opensuse.org/source/distribution/11.1/repo/oss/                      |
7 | repo-update              | openSUSE-11.1-Update     | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1/         

Additionally I want to say that the error message with kstartupconfig4 says that the error code is 3…

It seems that this time the solution was easier than the last time.

On my new machine I imported my old /home directory and it seems that I messed up the owner rights when I did this.

I fixed the rights per chown and now it works…

I’m sure that the last time the solution was much more difficult. If the problem will occur again I will inform you.

FYI: I would set Update repo priority to 99 to match kde4 Factory

Thanks for the hint!

I’ve recently been having trouble with this myself.

One of my users is running 11.1 and hadn’t updated their machine in a long time. As part of some other work I was doing for them, I ran all the recommended updates and suddenly they started getting the kstartupconfig4 error. The error probably had to do with new qt4 libraries or something that started conflicting with the matlab qt libraries already installed.

But I was baffled because I could log in to the machine with out incident whereas they kept getting the error and no amount of fiddling with the .kde or .kde4 directories had any effect.

I finally found that their .bashrc had a LD_LIBRARY_PATH pointing to the matlab libraries and that by removing this, they could log in.

Now I just have to figure out how to get matlab compiled code to run without having the LD_LIBRARY_PATH set in the .bashrc.