Can't login to KDE on X64 tumbleweed


I finally made the swap from Windows to OpenSuse (on my PHP devlopment machine) about 2 weeks ago after testing more than 5 distros and I love it. I’m currently running KDE 4.6.5 unless it was updated today.

This morning I installed the latest updates and then turned off. When I got back from work I cannot login to a KDE interface. I type my details in and the curser changes for a second or so but then nothing happends. I can login without a GUI but my knowledge of the linux shell is lacking (although getting better!).

I don’t really want to resinstall so thought I would ask for advice here first. I’m running lamp if this helps at all.

Any information you guys need then please feel free to ask. P.S. I know I shouldnt really be running tumbleweed but I really like the latest updates and don’t mind tinkering.



It might be the same problem as here:
xfce session crashes immediately after login

That thread does not have a solution (yet).

It looks as if tumbleweed might have broken gpg-agent.

I’ll assume that you are using kdm (or kdm4) as login screen.

My suggestion:

Login at the command line.

mv .gnupg  OLD.gnupg

I think that will prevent the attempt to start gpg-agent, which seems to be the problem.

If you don’t have “.gnupg” then my diagnosis is wrong.

Report back what happens.

From the login screen, you can select the command line option, (at the bottom of the screen if you are using kdm)

  • login as root
  • type the cmd “yast2” (without the quotes)
  • select repositories and change the priorities as given in “xfce session crashes immediately after login” etc.


When starting it now I don’t even have the enter username/password screen. I get a white console at the top right of the screen. Will give your suggestions a go when I get home.

Thanks a lot.


Just found out this morning this was keeping one of my accounts from logging on to GNOME 3. Indeed looks like a broken gpg-agent.


Unfortunately “mv .gnupg OLD.gnupg” did not work (it ran fine though) so I decided to reinstall. I took the opportunity to change some partition settings and have a cleaner install as messing around trying to get VMware installed did me no favours.

Just tried to install the new ATI 11.7 drivers (has anyone got these working with Tumbleweed?) with a 5870 but they didn’t work. Can someone give me a command to view my current installed driver. Sorry if I’m partying to much from the original topic!

Anyway thanks for the help :slight_smile:


Yes, finaly, in Tumbleweed (64) is something wrong with package “gpg2” with build date 2.8.2011. Login is succesfull only when dir .gnupg is deleted. After downgrade to gpg2 from openSUSE standard repo login is back as previous.

No experience with an 5870.

No problems encountered (via the hard-way?),
installed via
OS :-
AMD Phenom™ II X4 940 Processor, 4 GiB, Linux 3.0.0-39-desktop x86_64, openSUSE 11.4 (x86_64), KDE: 4.7.00 (4.7.0) “release 6”
ATI Radeon HD 3200 Graphics, Catalyst 11.7, 2D Driver 8.87.5, CatalystCC 2.13, RandR 1.3

for status try “sysinfo:/” without quotes from Konqueror command line and
if you have ati CatalystCC installed try “amdcccle” without quotes from a terminal

Problem with gpg is in libassuan. Anybody experiencing problems on Tumbleweed with gpg, should make sure that libassuan is installed from the Tumbleweed repo.

I had this issue this morning after applying automatic updates, although I was prevented from using any of my installed desktop environments except GNOME 2. By updating libassuan and gpg (and making sure that they were installed from the Tumbleweed repos) as Knurpht suggests, the issue was resolved.

Sometimes typing :

/sbin/lspci -nnk | grep VGA -A2

will tell someone which driver they have installed (but it won’t tell one the version).

Another way is to install the application ‘inxi’ from Packman and then run it with the command:

inxi -F

but by far the most reliable way is to look at the log file /var/log/Xorg.0.log and wade thru all the entries until one finds the entry on the driver and driver version.

/usr/sbin/hwinfo --gfxcard

That should show current driver for ATI card

Yes, solved this problem. BIG Thank. But i don’t know how could this happen? Before update i have “switched” to thumbleweed repo with better priority.