Can't login to KDE 4.6.1


I just updated my 11.4 installation to the newest KDE 4.6.1 from the KDE46 repos.

But know when i get to the login screen and i write my login information,i will just get a black screen and then get the login screen again.

I think i had the same problem with 4.5 on Kubuntu, and it was solved by reinstalling kde-base (I think, i can’t remember) but i tried that from a console login. I can login again if i downgrade to KDE 4.6.0.

Do anybody know who to fix this?

having experienced this also over upgrades, i suspect that there is merely config files from the previous install that don’t work properly in 4.6.1, my advice is:

if you previously had 4.5, do a console login as the user having the problem then issue from cli >

mv ~/.kde4/share/config/plasma* ~/(someplace)/(to)/(backup)

then go back and login normally, you should see the default plasma desktop, but all your application settings will still be there.

if you had <4.5, i’d recommend that you rename the .kde4 folder since there is likely to be changes that cause other applications to behave improperly… specifically dolphin and nepomuk (perhaps others). Same console login, then >

mv ~/.kde4 ~/.kde4old

you can move old settings back to the new .kde4 file that is created at your own speed and see if it causes problems.

should do the trick, good luck :slight_smile:

openSUSE starter: EXPERIMENTAL AREA - for experts only - THIS worked for me, so I’ve posted it there. It happened after upgrade from 4.6.0 to 4.6.1 - just do what point 1. says. No need to delete .kde4

Check out this thread for more info on this problem.

[SOLVED] Cannot login after update to Kde 4.6.1 on openSuSE 11.4](

Nice that worked. I simply selected the session.

Now how do i add Solved to the thread…

I see this a bit of an old thread, but I’m having this problem with a fresh install from the 11.4 KDE Live disk. On first login it does this. In this situation, would mv ~/.kde4 ~/.kde4old and mv ~/.kde4/share/config/plasma* ~/(someplace)/(to)/(backup) still work?

I can’t test this now since I have Mint running as a replacement for now.