Cant log in to Gnome

I have always used Gnome as my desktop manager but recently i decided to try xfce to see what it was like. Unfortunately the last time i used Gnome it froze and i had to do a hard restart. Now i cant log into Gnome it just starts xcfe instead. Any ideas why this may be/was to fix it?


Before powering off the computer, try CTRL+ALT+F1. This will take you to trminal mode. After making changes, CTRL+ALT+F7 will restore your X session.

It’s irritating that the Gnome Display Manager no longer gives an option of which DE to start. Check the file ‘/etc/sysconfig/windowmanager.’ Edit the line


Change this to “gnome” for the Gnome DE.

The default option is gnome and i can select it when i log in but it always starts xfce instead.

Try renaming the configuration directories in your home folder. Start with .gnome2 and .gconf

Might work…