Can't log in graphically after reformatting home

Last weekend I got a bunch of issues with my home partition, for example some files could not be read, and when I tried to read them I got errors in dmesg saying something like BTRFS critical (device sdb9): corrupt node, bad key. No idea why, but the system was overclocked, so maybe that had something to do with it. I copied what I could of the partition and tried running btrfs check --repair on it, but that made things worse, deleting a ton of stuff. So I reformatted the partition, now as EXT4 (because screw BTRFS), copied the stuff back onto it, and restored some backups I had of the most important stuff. I managed to save most of the stuff, but not all of it.
However now I am unable to log in graphically. When I try log in, the display manager just freezes, and if I go to a terminal and back I just get a black screen with the cursor on it. I’ve also tried logging in as a different user, in a different display manager, into a different DE, but get the same result. (and yes, I changed fstab, it’s getting mounted properly)
I then tried updating the system, but that didn’t help. I did however get another problem, at the end of the update I got “could not prepare boot variable no space left on device”. Googling about it I found something about deleting /sys/firmware/efi/efivars/dump-*, but I have no such files. The other solution I found was to boot with efi_no_storage_paranoia, so I guess I should try that.

Motherboard: Asus Z97-A
CPU: Core-i7 4790k
GPU: RTX 2080 ti
Driver: Nvidia 410.78

“No space left on device” coupled with “BTRFS” in a web search should have turned up results describing excessive snapshot space consumption. First thing to try is probably boot an older snapshot from before the trouble started, next to remove no longer needed snapshots. How big is your HD? How much space is devoted to /? How much to /home? If / is less than 40GB (it shouldn’t be), your simplest solution may be to reinstall, reusing /home as it is, and with / on EXT4 instead of BTRFS. How old is this TW installation?

The “no space left on device” is about the EFI NVRAM, not about any partition, as it happens when trying to set EFI variables.

Apparently, the home directories were owned by root, so that explains that.