Can't load user's graphical environment after nvidia driver installation

Hi to all! I have my first problem with drivers in Linux! I installed openSuSE 11.4 x86 on my computer (Intel Dual-Core 2,5 Ghz; Nvidia 7300 GS) and after installing graphical drivers (proprietary) I can’t load the system. All I have is a progress bar of user’s profile loading and playing the startup sound. I already installed openSUSE 11.4 x86_64 version on this computer and there was no problem with drivers.

Just out of interest, if you had the 64-bit version working ok why did you get rid of it for the 32 bit

I need to launch Lotus Notes. There is no Lotus Notes x86-64 version. Only x86.

On 07/20/2011 08:06 PM, firebolt wrote:

> I need to launch Lotus Notes. There is no Lotus Notes x86-64 version.
> Only x86.

all 32 bit applications i’m aware of run fine in a 64 bit openSUSE…


DD
Caveat-Hardware-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!

This is very good! But I ask you to solve MY problem with drivers. I want to install them in any case.

When you say you installed graphical drivers (proprietary) which ones did you try ?? ie EXACTLy what version ? Thats important !!

If nVidia drivers, and IF you selected the correct proprietary nVidia driver version, did you also disable modesetting in the Kernel , AND did you blacklist the nouveau driver BEFORE trying to install those drivers (and NOT after installing) ?

nVidia driver was from community’s repository, I don’t know it’s version. After I uninstalled this driver I downloaded driver from nVidia web-site, version 275.19. During installation the nouveau driver was disabeled (was created “nvidia-installer-disable-nouveau.conf” file in the /etc/modprobe.d/ directory). l don’t know how to disable modesetting in the Kernel.

I don’t use ‘the repository method’ when installing the nvidia driver so I can not help with that.

Reference disabling KMS in the kernel, look under YaST > System > /etc/sysconfig > system > kernel and there should be a setting there to change. Don’t forget to blacklist nouveau in /etc/modprobe.d/50-blacklist.conf file.

Problem was solved. The reason of issue was the nvidia driver version higher than 260 that crushes Plasma.