Can't load opensuse installer on new Asus Zenbook 13 (UX333FN)

Hi everyone, I have been using Opensuse since a couple of years,
today I bought the new Zenbook13 (UX333FN) and I was not able to install Leap 15.0.

After booting the installer what I got was a black screen with a white underscore char on the top left.
I tried burning the usb installer both with suse imagewriter and live-fat-stick.
The checksum of the downloaded iso was correct.

After trying for a while I switched to Ubuntu and the installer (burned with imagewriter) worked.
I tried also the live version of Leap 15.0 but again it did not work.

Of course this is an efi system and bios legacy is not available, also there is secure boot enabled and I could’t disable it.

I have not idea of what is going wrong, I would really like to use Opensuse and not other distros.

Thank you in advance, I am ready to give other informations.

This is probably a graphics driver issue.

On the boot screen, after selecting the “Installer” menu entry but before hitting the ENTER key, use the ‘e’ key. That should give you an edit window.

Scroll down until you find a line beginning “linux” (or, probably, “linuxefi”).
Hit the END key to get to the end of the line.
Append " nomodeset" to that line (without the quotes).
Use CTRL-X to resume booting.

Sorry, I badly explained.
I am not getting there, it gets stuck before the grub boot screen of the usb stick.

Hint: on some laptops (including mine) ASUS uses old EFI firmware that doesn’t read the double signature of openSUSE kernels correctly.
But they often include the Ubuntu signature, so Ubuntu installers load without a glitch.
It sounds odd to me that secure boot cannot be disabled, but sometimes ASUS do strange things.
I don’t really know if the above applies to your model, but it is worth checking IMHO.
For directions about secure boot and (double) signatures, nrickert is way a better source than me :wink:

For that, you would have to strip the second signature from “shim.efi” and write the replacement to the boot USB.

The boot USB will actually have a file “/EFI/BOOT/bootx64.efi” which is really “shim.efi” renamed. If you have a running openSUSE system, you can try using that system to strip the second signature. And then copy that file back to the same place “/EFI/BOOT/bootx64.efi” in the EFI partition (partition 1) of your boot USB. Note that I have not actually tried that, because I don’t have that boot problem. As far as I know, it should work. However, the boot USB is a hybrid structure and this might be messing with it a bit more than one should.

For instructions on removing that second signature, see this web page:


Scroll down to the heading “Booting the Machine that supports only one signature with vendor provided Keys”. And wherever it refers to “shim.efi” that will be the file “bootx64.efi” from your boot USB.

I was not able to substitute the bootx64.efi file with my version.
The mounted iso is read only so I can not change the file, I tried modifying its content with isomaster but the resulting iso can not be burned with imagewriter.
I was able to burn it using live-fat-stick but the result is not recognized.

However I found out how to turn off the secure boot, this is done by disabling the ‘secure boot control’ and then by rebooting the device.
The problem is that even with secure boot disabled and fast boot disabled, trying to boot the usb stick results in the black screen with the underscore.

The bios firmware is Aptio Setup Utility 2.20.1271 from American Megatrends.

I tried also with a linux arch live stick and it worked.

The Aptio firmware had the “double signature” problem (even if I don’t know for sure if your version might be affected). So leave FastBoot and Secure Boot off during install.
After installation you will be able to change the original shim.efi with a stripped version and enable Secure Boot if you need that.

Next, please be aware that the UX333FN uses bleeding edge technology, both in the Intel processor and the Nvidia GPU, so you might need a newer kernel and might have better chances with Tumbleweed, live DVD or full installer, which currently uses a 4.20 kernel.
Moreover, the Leap 15.0 installer has a bugged nouveau driver that might cause problems with your hybrid graphics ( please see ).
Personally I would run Tumbleweed for a few months on such new silicon, then maybe try Leap 15.1, which is in the works, if Tumbleweed is too much a hassle to you.