Can't launch Alacarte

I can’t lauch Alacarte menu editor, errors:

kuba@linux-w3pi:~> alacarte
Traceback (most recent call last):
File “/usr/bin/alacarte”, line 22, in <module>
from Alacarte.MainWindow import MainWindow
File “/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py”, line 33, in <module>
from Alacarte.MenuEditor import MenuEditor
File “/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py”, line 23, in <module>
from Alacarte import util
File “/usr/lib/python2.7/site-packages/Alacarte/util.py”, line 28, in <module>
from gi._glib import GError
ImportError: cannot import name GError

OpenSUSE 12.3 Gnome updated to 3.8 from Gnome stable repository.

Hi
A quick fix, as root user edit util.py;


vi /usr/lib/python2.7/site-packages/Alacarte/util.py

and change line 28 from;


from gi._glib import GError

to


from gi.repository.GLib import GError

Will look at push a fix into the 3.8 repo.

Fix was already in Factory, there should be an update in the G:S:3.8 repository soon :wink:

Thank you very much :shake: Topic solved.

Wow. 3.8 is not yet stable on 12.3. I will wait for 13.1:\

Thanks - fix has worked for me too lol!
Gnome 3,8 release is now perfect for me