Can't join domain with 12.3 or 13.1


If I join a domain with opensuse 12.3 or 13.1 it seems to be successful at first. However, when I reboot and go to login my domain is not an option to choose. Instead I have “local” and “null” as an option. I joined using yast. Also, with suse enterprise edition I can join the domain without any issues and everything works.

Please help me out what the i issue may be.


For anyone who has an issue with this… It ended up being app armor causing winbind to fail. I set winbind to “complain” in the app armor settings and now it works fine.

Well, I thought this was solved but it isn’t. I have my domain as an option on the login screen now but it says “login failed” every time I try to login. At first getent passwd or getent group was only showing local accounts but then I added winbind enum groups = yes and winbind enum users = yes to my smb.conf and it fixed the issue. I can su to any user on the domain using su user@domain. wbinfo -t -u and -g shows everything is good. On the domain controller I’m getting error 675 messages in the failure audit logs but even if I disable preauth on the server it still shows the same error.

Please help me out here.