Can't installl TDAmeritrade thinkorswim to openSuSE 12.2 (Gnome based)

The thinkorswim installer (bash script) runs, invoking a second, java-based thinkorswim installer, which runs until it invokes the GUI (X). This fails, reporting that X is not found. The installer was being executed via sudo in an xterm.

This same script ran successfully in January, 2012 on Ubuntu 10.04LTS, but does not on recent updates, having the same problem with attempting to access X. It runs successfully on Ubuntu 12.04, although there are problems after installation has completed, even with a local Sun Java 6 installed (and pointed to by the modified install script).
I have not tested this with a KDE install, only with Gnome 2.8 (Ubuntu 10.04) and Gnome 3 (openSuSE 12.2 and Ubuntu 12.04). All installs were up to date…

These problems are also discussed on Ubuntu forums at:

                    [java - Thinkorswim crash in 12.04 - Ask Ubuntu](


12.04 - Issues with TDAmeritrade thinkorswim - Ask Ubuntu

The crashing problem is due to open JDK 6, which spawns so many processes that it very quickly uses all available memory (even in a 6GB system). The only way to recover is to remove power – the battery from a laptop.

The command to launch a non-concole application with root privileges is ‘gnomesu’ for Gome and ‘kdesu’ for KDE.
For example, I use KDE and get these results

~> sudo dolphin
root's password:
dolphin: cannot connect to X server 
~> kdesu dolphin

The last command opens up a window asking for the root password, and then dolphin starts with root privileges (if I type the password correctly off course).

So, you need to change the script at that point…

In addition to billypap’s correct help that you must use kdesu to run dolphin or any desktop gui based application, have you considered using VirtualBox to just run Windows? Of course, you must have a copy of Windows, but it runs nicely in VirtualBox under openSUSE as the host. Have a look here:

AND Here:

Thank You,

On 10/11/2012 02:16 PM, octalman wrote:
> same script ran successfully in January, 2012

-=WELCOME=- new poster…

TDAmeritrade (and Datek, until bought by Ameritrade) has been my online
broker since 1997.

my experience has been that their Java offerings rarely (if ever) run as
expected in non-Microsoft environments…that is to say that in none of
OS/2, Windows 3.1 running in an OS/2 VM, nor in any of several flavors
of Linux has their JAVA applications performed well, consistently…

so, if you were able to run successfully for a while, consider yourself

their “Trade Architect” ran great for some months (in my openSUSE) and
then one Monday it just wouldn’t start…nothing changed here over the
weekend and Tuesday there arrived one of those self-congratulatory
announcements about the new great strides in technological prowess their
latest “Trade Architect” represented…

certainly, they made some changes and debugged them in IE and the MS
implementation of JAVA and . . .

no amount requests for TDA help got it going again…didn’t work for
about a year, and then one day, just as suddenly, it worked again…

i won’t hold my breath when it stops, again…

ThinkOrSwim i’ve never looked at but if it doesn’t run on Ubuntu, and
doesn’t run in openSUSE i’d guess it also won’t run in Red Hat or
anything else Linux…i think you might have to run real windows to
use it…(maybe Win in a VM…ask TDAmeritrade to buy you a windows
license…i did…and didn’t get a reply!)

good luck and happy trading.


None of that (Windows, or VM) is needed. TOS runs “fine”* under openSUSE (including 12.2; just checked).

  • I do recall that when I first installed it, several years ago, it was a bit tricky to do for some reason. I think that had something to do with the java version. Don’t remember. Anyway, all I have in the way of java installed at the moment is the latest openJDK v1.7. I don’t perform a new install of TOS for each new openSUSE version – I had originally installed it in the /home directory (perhaps that is the default location, don’t remember) and recycling that TOS installation keeps working (though see my comment about NetworkManager below).

  • I do not use it for trading, so can not attest to all the features of the platform as being stable or “fine”, however, that said, I have never had issue with their charting features that I access per se … TOS themselves, have on occasion, introduced bugs, that have affected charting, or even being able to launch the app in the first place (for that matter), but those are generally meet by large outcry (i.e. they, the bugs, affect their Windows users too) and are fixed with a subsequent release

  • One area I found that caused difficulty with TOS (introduced a while back) was updates to the NetworkManager package… after entering your login info in TOS, the app just hangs. I forget exactly how I tracked it down to the NetworkManager (I think it was a combo of examining TOS’s log and the java error log, and then, after googling the java error line, by fluke of finding an offhand comment in some really obscure thread, well off the beaten path, wherein some user was trying to troubleshoot a very similar java error when launching some completely different application). I don’t remember if it was to do with IPv6 v. IPv4 setting (I think it appeared like that might have been the case, but that might have been a red herring, I don’t remember). But anyway, through troubleshooting the matter myself, I then proceeded to discover that (if when running with NetworkManager handling the network settings) that the launcher hangs, switching to the traditional ifup would resolve the TOS issue and it could again launch. In fact, right after doing that, you can go into the network settings and switch back to NetworkMangager and TOS will no longer have any hanging issues when launching. This works across reboots, shutdowns, etc. until NetworkManager receives another update. Then you have to do the same step just described to get it (TOS) working with NetworkManager again. I’m sure its something really simple, but I don’t really care to investigate what changes are invoked by the NetworkManager version updates, as my work around is pretty painless. (Note: to check to see whether TOS is working on 12.2 I had to do these very steps, as I haven’t fired it (TOS) up in a while. And, as reported, it is!)

sudo works for me in the Gnome enviroment, running the script as requested. It’s the java coded part that fails to connect to the X server. It appears that there’s a second part of the installer that’s written in java, though the issue may be the main ToS java code itself. I tried installing a “local” copy of sure-nuff Sun Java 6 (update 35), but the problem remains. I’m successfully running like this (local Java 6 install) with Ubuntu 12.04, though there’s a problem with the install persisting after the program is minimized or killed – apparently a problem with Ubuntu’s implementation of Gnome 3.

  1. If you run “sudo some command” that requires X-server this is absolutely normal to get that error. Just go ahead and install TOS as “normal” user (basically just following the instruction from TD website…)

If you still want to run that installer under root user use a corresponding kdesu (or corresponding tool for Gnome) to run that installer command.

In your case run:
2) TOS platform is working fine on Ubuntu 11.04, 12.04, SuSE 12.1, 12.2. (Both 32 and 64bit). So, if it is not working in your case - this is something wrong with the configuration.

Thinkorswim will run under Ubuntu 12.04 and openjdk6 if the splash screen is disabled. If it can’t be disabled locally, call TDAmeritrade Tech Service and ask them to disable it for your account.

However, this isn’t enough to get ToS to run on openSUSE 12.2, whose java environment is openjdk7. The problem is that ToS uses t3s protocol to securely connect to the TDA server when signing in with username and password (as reported in the client.log file, “Name or service not known”). Apparently, openSUSE doesn’t have t3s protocol installed or enabled in the standard install, and I haven’t found a way to do so.

Following Tyler_K’s suggestion, I checked the network configuration – after finally finding it in openSUSE’s incredibly poorly laid out program menu. The default configuration is to use traditional ifup. When Network Manager is enabled in my fresh, up-to-date 12.2 install, it says another module needs to be started manually, a poor design setup. If it needs something, just do it! Or, at least provide an easy way through the configuration display to do so. I do know nx CLI quite well, but I just don’t have the time to put up with a lot of unnecesary extra effort.

I used SuSE Linux from mid-1999 through 2004, only abandoning it after SuSE was bought out and SCSII support discontinued in the install package – my boxes had SCSII drives. I’m very disappointed in openSUSE. YaST and YaST2 were the shizazz ten years ago, but Ubuntu’s software management system is far easier to use these days, though 12.04 was a major step backward from 10.04 in many ways.

On 05/06/2013 07:06 PM, octalman wrote:
> but Ubuntu’s
> software management system is far easier to use these days, though 12.04
> was a major step backward from 10.04 in many ways.

so use it! use what works for you…i do!

but, i don’t go to the places which produce a distro that “I’m very
disappointed in” to post about my disappointment!!

i just wouldn’t expect anyone in those other distro places to really
care what i didn’t like about their chosen system…

by the way, TDAmeritrade has been my online broker since the '90s
(when they were Datek) and have had one disappointment after another
with their programs…to me it seems they program for the masses
(Windows) and seldom have i had good luck with their programs on any
Linux or OS/2 system…