cant install vlc

hey … i had installed vlc on my previous installation of opensuse11.0 but now when i am tryinf to install it from yast it gives following error File ‘./noarch/iso-codes-2.0-16.1.noarch.rpm’ not found on medium 'http://download.opensuse.org/distribution/11.0/repo/oss/'
help…

First lets see what repo’s you have

in a terminal

zypper lr

this is output when i did zypper **]Alias | Name | Enabled | Refresh
–±-------------------------------------------------------------------±-------------------------------------------------------------------±--------±-------
1 | repo-debug | openSUSE-11.0-Debug | Yes | No
2 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
3 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
4 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
5 | Index of /repositories/home:/cubo/openSUSE_11.0 | Index of /repositories/home:/cubo/openSUSE_11.0 | Yes | Yes
6 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | Yes
7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes ** |

… i have added packman,videolan,oss,non oss reposterios …to my yast reposteries…
help…

Ok
First
Go to Yast - software management
Filter by repo
select vlc/videolan repo and make sure you have libdvdcss ticked, if not tick to install.
Once you you have that, disable vlc/videolan reo

Now again in software management
filter by repo
select Packman

Now, from the top left ish of your screen click the packages tab and select update all in this list unconditionally.

Now scroll down the list and make sure VLC is checked for install or it will show as update if it was already installed.

accept

leave vlc disabled
you should end up with only libdvdcss installed from there

this is output when i did zypper ]Alias | Name | Enabled | Refresh
–±-------------------------------------------------------------------±-------------------------------------------------------------------±--------±-------
1 | repo-debug | openSUSE-11.0-Debug | Yes | No
2 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
3 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
4 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
5 | Index of /repositories/home:/cubo/openSUSE_11.0 | Index of /repositories/home:/cubo/openSUSE_11.0 | Yes | Yes
6 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | Yes
7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes |

… i have added packman,videolan,oss,non oss reposterios …to my yast reposteries…
help…

DID YOU DO THIS

Ok
First
Go to Yast - software management
Filter by repo
select vlc/videolan repo and make sure you have libdvdcss ticked, if not tick to install.
Once you you have that, disable vlc/videolan reo

Now again in software management
filter by repo
select Packman

Now, from the top left ish of your screen click the packages tab and select update all in this list unconditionally.

Now scroll down the list and make sure VLC is checked for install or it will show as update if it was already installed.

accept

leave vlc disabled
you should end up with only libdvdcss installed from there

No need to shout!

Geoff

Shout not intentional
Just not paying attention - sorry prakhar3003, geoffro

IMHO thats why one often has to be a bit more verbose, and provide the reasons behind a recommendation - without the reasoning, the importance is simply lost and not understood.

Of course, I am guilty myself on many occasions of not providing explanations as well.

prakhar3003, an explanation … some of us have discovered that vlc and the codecs as packaged by videolan, are not compatible with the packman packaged video players nor compatible with the packman packaged codecs. Which in essence means you can use Packman packaged multimedia, or Videolan packaged multimedia, but not both. If you try using both, and if you do not understand the precise limitations, one can run in to the sort of problems that you ran into.

Now the one package that only videolan provides, which is useful (for dvd playback) is libdvdcss2. So since only videolan provides that, while you still have your videolan repos, install libdvdcss2.

Then after that is installed, per caf4926 recommendation, remove (or disable) the videolan repos. Then using packman as your repository source, replace any videolan packaged apps (except for libdvdcss2). ie install packman packaged libffmpeg0 and packman packaged vlc.

prakhar3003
You are in the hands of the Master Now (oldcpu). Thanks for that clarification oldcpu. You are quite right.

Apologies all round for my unnecessary brevity and hard hitting reply.

in new wake of experimentation … i changed the priority value of each repo set by Yast automatically … plese can some one pls guide with correct priority values…

Default is 99 (if you press the help button in the repo manager it explains)
But it’s not going to solve your problem with vlc really.

original post by Omniscient Penguin

Ok
First
Go to Yast - software management
Filter by repo
select vlc/videolan repo and make sure you have libdvdcss ticked, if not tick to install.
Once you you have that, disable vlc/videolan reo

Now again in software management
filter by repo
select Packman

Now, from the top left ish of your screen click the packages tab and select update all in this list unconditionally.

Now scroll down the list and make sure VLC is checked for install or it will show as update if it was already installed.

accept..

thank u old cpu … but i am getting same error after all that recommended by Omniscient Penguin
cannot access installation media
openSUSE-11.0-OSS(Medium 1)
check whether server is accessible…

OK
Remove oss, no-oss, and updates

then add them back with these

Main OS Repo’s and Updates

OSS:
Index of /distribution/11.0/repo/oss

Non OSS:
Index of /distribution/11.0/repo/non-oss

Updates:
Index of /update/11.0

now try

thank u everybody for help … problem solved