can't install virtualbox on geckolinux based on leap 42.2 live

i was trying geckolinux cinnamon ( based on leap 42.2 ) live

everything was working well but when i tried to install virtualbox i couldnt
zypper told me that a package needed to be uninstalled first

but then when it tried to uninstall it it freezes on 5%

i repeated the process but still the same

here are the screenshots :

p.s : that error only appears after i cancel the operation , otherwise it would remain on 5%

Hi, not sure that you are going to get help for Geckolinux here, but on a general note:

  1. are you trying Geckolinux on real HW or on a Virtual machine?
  2. IF you are running on real HW, you DON’T NEED any virtualbox-guest***, so uninstall them manually BEFORE attempting to install virtualbox.

If you are trying Geckolinux on a Virtual machine, I bet that you cannot install virtualbox there…

1 : yes i’m trying it on real hardware
2: i tried this again a minute ago , and still the same thing

i suspected the DVD itself , so i tried the same iso in virtualbox and it did the same thing
so does the mate version

so i rechecked the md5sum and i have the right download

should i report a bug ?

My guess is that since GeckoLinux is a cut down version of openSUSE with many things left out maybe the VirtualBox guest package may have been left on the cutting room floor.

Report to GeckoLinux not to openSUSE

IMO you should try “solution 3” if the first option doesn’t work…

For the HostOS, although the kernel Guest modules might not be required, I don’t know that leaving them installed should cause any issue. The important thing is to get the host modules installed. Another possible issue is that you should verify you have the default and not desktop kernel flavor installed. You can see what kernel is installed and used by running the following command in an elevated console

uname -a

If installing Virtualbox using openSUSE packages won’t work, you can also install from the Oracle Virtualbox website


I tried a different Geckolinux version and uninstalling virtualbox-guest-kmp-default took a while, the progress bar stayed at 5%, the system seemed frozen but eventually it triggered dracut to rebuild the initrd and the job completed successfully.
Maybe you have to just wait a bit longer?

i tried again and waited for very long but no success
maybe i could try again and leave it working while im sleeping

here’s the ouptut after selecting solution 3 :

linux@linux:~> sudo zypper install virtualbox
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: virtualbox-5.1.8-3.3.x86_64 requires virtualbox-host-kmp = 5.1.8, but this requirement cannot be provided
  uninstallable providers: virtualbox-host-kmp-default-5.1.8_k4.4.27_2-3.3.x86_64[openSUSE-Leap-42.2_OSS-updates]
 Solution 1: deinstallation of virtualbox-guest-kmp-default-5.1.8_k4.4.27_2-3.3.x86_64
 Solution 2: do not install virtualbox-5.1.8-3.3.x86_64
 Solution 3: break virtualbox-5.1.8-3.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): 3
Resolving dependencies...
Resolving package dependencies...

The following NEW package is going to be installed:

1 new package to install.
Overall download size: 11.4 MiB. Already cached: 0 B. After the operation,
additional 33.9 MiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package virtualbox-5.1.8-3.3.x86_64
                                           (1/1),  11.4 MiB ( 33.9 MiB unpacked)
Retrieving: virtualbox-5.1.8-3.3.x86_64.rpm .................[done (95.5 KiB/s)]
Checking for file conflicts: .............................................[done]
(1/1) Installing: virtualbox-5.1.8-3.3.x86_64 ............................[done]
Additional rpm output:
setting /usr/lib/virtualbox/VBoxNetDHCP to root:vboxusers 4750. (wrong permissions 0750)
setting /usr/lib/virtualbox/VBoxNetAdpCtl to root:vboxusers 4750. (wrong permissions 0750)
setting /usr/lib/virtualbox/VBoxHeadless to root:vboxusers 4750. (wrong permissions 0750)
setting /usr/lib/virtualbox/VBoxSDL to root:vboxusers 4750. (wrong permissions 0750)

here’s the result from

uname -a
Linux linux.suse 4.4.36-8-default #1 SMP Fri Dec 9 16:18:38 UTC 2016 (3ec5648) x86_64 x86_64 x86_64 GNU/Linux

Congratulations, that looks like you have successfully installed Virtualbox: does it launch and work properly?
PS: remember to add your normal user to the “vboxusers” group.

it worked after selecting solution 3, then installing virtualbox-qt and adding my user to the “vboxusers” group

thanks for the help everyone :smiley: :smiley: :smiley: