Cant install system, Black Screen installation

Hello, I have a problem trying to install Leap 42.1 i cant seams to initiate the installation. the installation loads and when the GUI initiate i can see the initial screen and after 2 seconds it just go blacks screen. no tty1 , no console or anything it just hangs. And i have re download the iso. tested with DVD, different USBs etc. I have to assume the problem is related with my video card. Im using ATI HD7870. I have try to load the boot process with UEFI and with legacy, but and same problem. I have successfully installed 42.1 in my laptop, but the laptop has intel graphics so no big deal there. But i want to install it in my main pc too. any help here?

oh also this also happened with opensuse 13.2.

INTEL CORE i5 4670K OC @ 3.4GHZ
Gskill 16GB RAM DDR3
ATI HD7870

I already try to turn off the Over Clock but still the problem persist.


Try to boot the installer with “nomodeset” graphics:

when at the “Install” prompt, type E (for Edit)
go to the line beginning with “linux” or “linuxefi” (depending on your BIOS)
append “nomodeset” (without quotes) to the end of that line
press F10 to boot

that should give you at least a basic graphics interface to perform installation, including installation of a proper driver for your ATI chip.

Thanks I’ll try this tonight and I’ll post results !!

tried the nomodeset and didn’t work. the resolution indeed is lower at the moment to boot but again it freezes at the same point.

i have to add that the installation freezes, it dont respond to alt+ctrl+backspace or tty1

This same ISO i already downloaded two time. used different USB’s and i also tried with OpenSUSE 13.2 and the result is the same. it freezes in the same exact point.
I been able to install Leap in another computer, but not in this one. But in this system i been able to install Fedora and also LinuxMint 17.2.

any one with any idea on how to solve this?

picture of death here. →

the mouse freezes and crtl+alt+del or anything at all does not work.

Possibility: Check that your memory is okay.

It was the overclock that was causing the issue. removed the overclock settings and i was able to proceed with the installation. After the installation finish i turned back on the overclock and everything is working ok.