Can't install SUSE 12.1 properly on a RAID 10 multiboot

Hi there,

I’m having a problem, earlier on tonight I was trying to install the latest version of Suse 12.1. I haven’t used Linux for a few years now and I’ve forgotten some of it when I used to mess around before. I’m hoping to get back into Linux again and may even buy a good book so I can read more on the subject.

I downloaded and burned the latest version of Open SUSE 12.1. Now beforehand when I was using linux several years ago I used to install it on a multiboot system with Windows XP. I didn’t used to have problems but now I have a RAID system. I tried to install it earlier on but it didn’t work and it’s a shame because I set the installation as best as I could and I was about 99% sure that I’d done it right… but obviously when it came to trying to boot it, it was messed up. I nearly messed my Windows XP up also but I managed to fix that by removing the partitions that Suse had created and then simply fixed the master boot record by using an old Windows '98 floppy and typing the command fdisk /mbr It worked anyway and I was able to get back into Windows XP.

The problem is that I wasn’t sure why it didn’t work but it just hit a blank screen and it didn’t start grub up properly. What I did wrong I just don’t know. I have a RAID 10 setup, the RAID 10 volume that I have is about 1.8 TB and what I do is partition that into 4 primary partitions normally with Windows. I decided today to delete the last partition on the disk which is about 465 gigabytes. All the partitions on my RAID 10 volume are of equal size. All I want is to put Suse 12.1 on a partition but I think it might be too big if it’s 465 gigabytes. I am running 4 hard drives in RAID 10 that are 1TB each. I do like the RAID setup and I want to keep it that way, I also have another RAID on the same setup on another machine I have.

How do I get Suse to install on this then? I had a go before, I was very careful looking at it first and I made sure that it was gonna install the Suse partitions on the last part of the volume, the one where I’d unallocated space of 465 gigabytes.

Not sure with this one so I’m asking for help on this forum, I’m sure there’s people who can help me here. I know there are lots of people around especially on this forum who know a lot about what they’re doing with Suse. I have used Suse before a few times and I do like it so I don’t want to try and use something else. I just want to multiboot between Windows XP and Suse 12.1 with grub and use a fairly decent size partition to keep Suse in. The rest of the partitions I want to keep as NTFS partitions for Windows. I like how you can use Suse for reading Windows NTFS partitions also, another reason to keep using Suse.

If I can figure out where I’m going wrong and I can get it installed properly, then I may well buy a good book, was looking for something on Amazon before. Obviously I need to learn more things with Linux so I can go further than I did a few years ago. I only got so far before so learning it more would be fun. Any of your help is greatfully appreciated.

Also I forgot to mention that I’m using the 64 bit version of Suse 12.1 here. My machine is fairly high spec anyway so I don’t see a problem using 64 bit. I have about 4 gigabytes of DDR3 memory. My machine was all built new towards the end of last year so there’s no old bits or anything.

Well two things come to mind, one is what type of video do you have? If its AMD or nVIDIA, you may need to use the kernel load option called: nomodeset, something you can type in, from the Grub OS selection menu, before you press the enter key to select the normal openSUSE startup.

Second, I would boot from a LiveCD and see if the RAID can be seen and accessed. If it can, it works, but perhaps Grub Legacy in openSUSE 12.1 just can’t boot from it. A small, secondary drive might be needed to get you booted up, before you come online. For instance, on many systems you can not boot from a USB3 drive, but you can mount it and use it after booted up and have the kernel loaded. It can be the same issue with your RAID drive.

Thank You,

My graphics card is an AMD card, a Radeon HD5670 to be exact.

I was thinking if I can’t multiboot Suse 12.1 and Windows XP together on a RAID 10 configuration then perhaps it would be better to forget using the RAID for linux. Instead I could purchase a cheap drive, I have seen one just before. I’m not sure if it’ll allow me to connect anymore drives now though, I’m gonna have to open my computer and check to see how many cables I have left from the PSU. If I can’t put another drive in then I might forget Linux full stop. It’s annoying really, I guess then maybe just not bother with Suse and carry on with Windows XP all these years.

It has been a while though since I’ve installed Suse Linux so I’ve forgotten lots of things. If I can actually put another drive into my computer then I guess I could install Suse on that and then just select from the bios which one I want to boot, that would be easier so if I want to use the RAID with Windows XP then I could just select that and if I want to use the Suse Linux then just select that instead.

It seems like that’s how I’ll have to do it, I’ve never done it like that before but if grub won’t work with a RAID 10 I guess I’m snookered.

I was also thinking before, this I’ve forgotten about and I’m not sure anyway… The thing with Windows XP, to get it to work with a RAID you need the raid driver. So when I installed XP when I built my machine originally I got the driver from the motherboard’s disc. It gave me an option to copy the RAID driver to a floppy disk. So I did that and then when it came to installing XP you just wait until it asks you and you hit one of the function keys (forgotten which one at this exact moment) and then it loads the RAID driver so that your XP can boot from the RAID… Yay!! hey presto…

The question is, can’t you just do something like this for Suse 12.1? I mean you’ve got to expect this now, RAID has become more common and they’re shipping these latest Intel boards with RAID on them so people are using it. Instead of going the microsoft route and you choose to go the linux route instead, surely there are ways of putting a linux OS onto a machine with a RAID configuration? I really have honestly never tried anything like this before so this is why I’m posting on here about it.

I know it does complicate things more with having a multiboot system, if only I knew more about how Grub boots to the menu and why when this is 2012 that Grub can’t boot up to a menu from a RAID 10??? Surely it should be able to do that or have I found a problem?

I’m not sure what was going on last night with my video driver, I couldn’t even get the Suse OS I’d put on to even reach the boot menu. All I got last night once it had got past the bios screens and the RAID screen was a blank screen that had a slight flicker… Surely when Grub comes on at that point it doesn’t need the graphics driver as it’s only a boot menu so??? What on earth does that mean?

Well did the RAID maker have LINUX driver? They are the ones that ought to supply such things. BTW what RAID is it is it a real Hardware RAID card or some BIOS assisted RAID?

Basically it should work on real RAID hardware it is hit or miss if it works for BIOS assisted (FAKE) RAID.

Yes mate, it is a BIOS RAID, it came on my motherboard.

I decided to have RAID 10 as I wanted my data to be mirrored and also striped over the other two drives.

I know this is a shame it won’t work, I guess it’s probably down to it being a motherboard RAID. Nevermind, I have taken action now…

I have just bought a cheap drive from a local computer place, I’ve got a Western Digital 160 gigabyte SATA II with 8MB cache. It was only £37. I’m gonna put that in my machine (I have the spare room for a fifth drive anyway) also I looked and I can plug in a spare power connector from my PSU and also I have a couple of free SATA ports on my motherboard.

I’ve just bought a book also, this one:

I really need to read up on that book, it seems to be the book for me.

Hopefully I can get Suse 12.1 onto that new drive I’ve bought. Just simply swap the BIOS over when I want to use the Linux drive, otherwise I’ll just set the RAID to boot instead. I’m not bothered about all that multiboot stuff like GRUB. It doesn’t matter.

But yes I need to read plenty in that book and get back into Suse again.

Sorry yes, the answer to your question, I was just looking at the manual for my motherboard and the motherboard installation CD. It appears that they only support Windows computers. There is no mention of Linux anywhere to be found! I have no idea, if they don’t support a Linux driver then I guess it’s a complicated issue. My motherboard is an ASUS P7P55D-E

On 2012-04-30 23:36, Cigar126 wrote:
> here is no mention
> of Linux anywhere to be found! I have no idea, if they don’t support a
> Linux driver then I guess it’s a complicated issue. My motherboard is
> an ASUS P7P55D-E

Assus is not Linux friendly.

Sometimes the necessary raid driver is reverse engineered and the raid can
be used from Linux. This takes time to do, and anyway, I’m not familiar
with the procedure to use them. There is a chance that once you load Linux
in your new disk the array will be seen.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I would again ask if you have tried booting from a LiveCD using openSUSE 12.1 to see if the RAID might be seen or usable after the kernel is fully loaded. It is worth a try to see.

Thank You,

I just tried mate but no luck. I booted up the LiveCD but there was no chance of it seeing the Windows RAID. I’m not bothered about accessing the RAID that I have anyway in Linux, I just want to run Linux on a small drive, I should have a new drive tomorrow hopefully so I can try it out tomorrow night. I was also thinking that when I’m not using Windows to change over to Linux I will first have to enter the BIOS and then change the device to boot which will be the new small drive I’ve purchased. Also I will have to change the SATA mode in the BIOS because normally I have it on RAID mode, so therefore I shall have to swap it back to IDE mode instead.

Then when I’ve finished with using Linux it’s a case of setting the boot device of the RAID volume and also changing back the SATA mode to RAID again.

I can’t see any other way of doing this, if I’m going to use the same computer for both Linux and Windows then I have no other alternative. When I tried a couple of days ago to install it on the RAID volume it just messed up and Grub wouldn’t even start so that must be bad. Like I said in my original post I was 99% sure that I’d setup the installation of Suse 12.1 as best as I could. To be honest I couldn’t have tried it any better really. I guess it’s not good with a BIOS RAID and also Grub can’t boot from a RAID volume.

Well if you used the RAID drive as a data drive to Windows, you could place the Windows and openSUSE boot partitions on this same (new) hard drive and when you boot Windows, the RAID drive would come alive. Its a way you could use a single boot process for both OS’.

Thank You,

Interesting idea, I like the way you’re thinking here. The thing I don’t understand though if I did do that then which SATA mode would I have to enable in the BIOS? If I didn’t have the RAID mode selected then the RAID won’t function from the BIOS but if I don’t have the IDE mode selected then how could I possibly run a single drive which allows me to boot two OS’s? Both Windows and Suse Linux?

Thinking about it though, I don’t want to have to install Windows XP again because I’ve got it working nice at the moment and all my programs and things as I want them so doing a clean install of XP would be an annoyance.

The problem is that if I use this new drive that I’ve just bought it’s only 160 gig so I would probably have to split it in half for each one. 80 gig for XP and 80 gig for Suse. That’s not a lot of drive space really left for Suse. Only 80 gigs is a bit ****. That’s not that much in this day and age. This is the reason I put a big raid together so there’s lots of room on the drives.

I can’t go back now and get another drive, besides I can’t afford an expensive drive anyway as they cost a fortune and I’m hard for cash these days. I’m only doing this for a bit of fun with Linux, I don’t want to resort to spending massive money on something like this.

I think I will have to go with the previous plan, that sounds like a better idea to me. Trying to put a drive in that you have to keep changing the SATA mode in the BIOS sounds silly. To be honest I can’t even get my head around that SATA mode thing, it’s either one or the other. You can’t on my motherboard select which SATA ports you want for RAID and which you want for IDE mode. They’re just not as good as that, certainly the board I got can’t, it’s a nice board for the price but that’s about it really.

On 2012-05-02 01:16, Cigar126 wrote:

> Interesting idea, I like the way you’re thinking here. The thing I
> don’t understand though if I did do that then which SATA mode would I
> have to enable in the BIOS? If I didn’t have the RAID mode selected
> then the RAID won’t function from the BIOS but if I don’t have the IDE
> mode selected then how could I possibly run a single drive which allows
> me to boot two OS’s? Both Windows and Suse Linux?

In my machine the raid mode only affects some sata sockets, not all.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

So, I don’t know how many SATA ports you have, but often they work in pairs. What ever port it is plugged in to, if you can select it as a boot drive, it should work I would think. As for a dual boot setup, it is just too bad you must go into your BIOS each time to select the boot drive. It might be one of those times where you use the old WinXP boot.ini file to start up openSUSE. I have done it before, way back when and it could work for you as well. You would start Windows normally, but have two select options, one for WinXP and the other to essentialy chainload the openSUSE grub boot loader. Anyway, its worth a try.

Thank You,

Sorry but you’ve lost me a bit now. I thought I had already come up with a solution to this. I have 6 SATA ports on my motherboard. The first 4 I have my four 1TB hard disks plugged into them. The 4 drives are working together on a RAID 10, 2 stripe and 2 mirror.

The last 2 SATA ports are free because I use the IDE ports for plugging my DVD-Rom and DVD-Writer drives into the motherboard. SATA ports 5 and 6 aren’t being used so I was going to plug this new drive I’m getting into SATA port 5. Then I can use my machine as normal by selecting in the BIOS the correct boot device (the RAID 10 volume) and also the correct mode (SATA mode RAID).

Now with all being said, if I plan on using Suse Linux then all I have to do is boot, enter BIOS, change the SATA mode to IDE, change the boot device to the new drive I’m installing on port 5 and… hey presto! It means that I can run Linux on a single SATA drive.

As far as the RAID is concerned, it’s not necessary whilst using Suse Linux, I can learn how to use it once I get this book I’ve bought. Also 160 gigs should be more than enough space for my Suse to run in.

I won’t be swapping back and forth all that often, it is a simple choice for me either Windows XP or Suse 12.1. A case of, 2 changes in the BIOS and it will work that way. I can then forget the Grub bootloader. The Suse installation won’t have anything Windows related when it is running on it’s own, no mounted Windows partitions or anything because as I proved earlier on today, the LiveCD version won’t read the RAID. Waste of time with the RAID. If Windows will run it… but Linux won’t, that’s fine by me :slight_smile:

In the end, if you are happy with the setup, then so are we. For questions about modifications of the WinXP boot.ini, have a look at these links:

How to Use and Edit Boot.ini in Windows XP

How to edit the Boot.ini file in Windows XP

For any such solution to work, your openSUSE installation should use a generic boot loader, grub is loaded into partitions 1, 2, 3 or 4 only and the openSUSE partition should be marked active for booting. Good luck in what ever you decide to do.

Thank You,

On 2012-05-02 03:16, Cigar126 wrote:
> I won’t be swapping back and forth all that often, it is a simple
> choice for me either Windows XP or Suse 12.1. A case of, 2 changes in
> the BIOS and it will work that way.

As long as when running windows you board doesn’t try to integrate that 5th
disk as part of the array…

You might also run Linux virtualized.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Brilliant news… lol!

I managed to fix it, couldn’t be better than ever. I got the new drive today, installed that earlier on and I noticed there’s an option to select the hard drive you want to use in the BIOS… but… it doesn’t matter cos I’ve now installed Suse 12.1 and it’s working. I managed to put the Suse installation on the new drive on its own and it could also read the RAID. This time it worked! :slight_smile: Thanks for the help, it was the best decision to buy another drive. It’s lucky I have room in my case for 5 internal HDD’s. When the machine boots up it says that the 160 gig drive I installed today is a Non-Raid Disk. It’s great, I have the RAID 10 Volume set as the boot device, then when I boot Grub starts and I can just select either Suse or Windows. No need to keep messing around with the BIOS settings…

Fantastic stuff! Things have really gone my way today, I got the book also the one I’ve bought from Amazon. I’ve been having a look today, great book, teaches you all sorts! Anyway I’m so pleased about all this. Thanks to those on this thread who helped me suceed in this matter.

I shall be back more soon with more linux problems! If I can’t figure them out on my own.

Thanks again…