Can't install spotify on Opensuse 13.2

When I try installing spotify (using install-spotify) on Opensuse13.2.20150209 (64 bit) I get the following error: “link target doesn’t exist (neither in build root nor in installed system): /opt/spotify/spotify-client/lib/ -> /opt/spotify/spotify-client/ Add the package providing the target to neededforbuild and Requires
error: Bad exit status from /var/tmp/rpm-tmp.WGVTSi (%install)”

I tried installing appjs-0.0.20-1.fc20.x86_64.rpm but this hasn’t helped.


I have no idea why you installed that but I tried install-spotify on my computer and it splurted out an RPM, you might want to test if it works:

64-bit only, didn’t try it out myself. Install it with zypper so it resolved any dependencies on its own.

I wrote a small tutorial for installing Spotify on openSUSE 13.1 and 13.2 is more or less the same. You can read it (in spanish but can translate with google translator with no problems).

Remember to access the first link in the post in order to know how to download spotify deb file from Ubuntu repositories.

Hope it helps. If you have any problems, you can reach me at

I made an RPM from the Deb package. I extracted the binaries and wrote a half decent spec file to go with it to ensure proper dependency resolution on SUSE

I tested it on Leap, Tumbleweed and SLE 12 which is what I use…86_64.rpm?dl=0

I made an RPM from the Deb package. I extracted the binaries and wrote a half decent spec file to go with it to ensure proper dependency resolution on SUSE

I tested it on Leap, Tumbleweed and SLE 12 which is what I use

All the Spotify install scripts for openSUSE appear to be unmaintained or broken so I decided to make an install script myself


I’ll pitch in here. I experienced that all those scripts didn’t worked the hard way. So I learned how to do it all manually.
I haven’t tried your script @megamaced but hopefully it works. I might try it someday.

My original thread is closed so I cannot add anything to it:
So I’ll write my instructions here. This is also a self note or documentation for me so I can go back and read this in case I need look it up.
I have done this both on 13.2, leap 42.1, 42.2. Tumbleweed 13.2 and Tumbleweed 42.2.
I cannot verify It works today. But it worked in December 2016 during x-mas weekends when I was setting up one of my laptops.

This is a static installation of Spotify. You will not get any updates on the software because there is no repository added to your system.
Keep this in mind. But this is exactly how I want it. I am in control. If I want to update the software I will do this manually.

Dependencies needed to rebuild an .deb to .rpm
• Alien:
• Rpmbuild:

You need to find the binary file of the Spotify version you want to use.
You can download the latest version here on spotifys server:
But what if you wish to use an older version of spotify on linux? Black or the oldest grey UI.
Spotify remove the old binary when a new is released so keep your copy if you wish to use it long term.
But luckily there is an archive on github that hosts at least some of these older binaries.
Go to:
Download your desired version. Then follow the same steps below.

Notice: Of course you need to replace the name of the file with the one you have when typing the terminal command.
From PvdMWiki
This guide shows you how to install spotify client on openSUSE 12.3
As there is no native openSUSE rpm, we will have to make one ourselves.
The big advantage of this method is, that we will always have the latest version, because
when a new version is released, we can bake a new rpm ourselves and don’t have
to wait on others.

Here are the steps:

  1. browse to and download the appropriate 32- or 64 bit version.
  2. install the rpm package ‘alien’ to convert .deb to .rpm’s. This can be found in the opensuse repos, to be exact here:
  3. use alien to convert:
#alien -r spotify-clientxxxxx.deb
spotify-client- generated
  1. then, install the rpm:
#zypper in spotify-client*.rpm

you will get a libcrypto dependency error, but you can ignore that, choose 2:

Solution 2: break spotify-client- by ignoring some of its dependencies
  1. typ the following:
 ln -s /usr/lib64/ /usr/lib64/
 ln -s /usr/lib64/ /usr/lib64/
 ln -s /usr/lib64/ /usr/lib64/ 
 ln -s /usr/lib64/
 ln -s /usr/lib64/
  1. that should do it. Have fun!
    Retrieved from:

If you wish to remove visual ads from the horizontal bar popping up you can add these entries to your host file.
There is no way to remove audial or visual video ads because these runs through and and so on servers.
Its packed in with the audio stream and all other data. So there is no single host that pushes the ads on desktop clients.
On android an IOS its way easier because it runs through 3’rd party servers easy to block with the host file.

If something don’t work perhaps you, we or I can find some solution to what’s not working in my guide and PvdMWiki.
Its also a good backup guide in case spotify-easyrpm will break or go unmaintained.

I forgot to include two dependencies.

If you cannot start spotify after installation is finished.
Start spotify from terminal to get some verbos information.
It will tell you if any dependency is missing if its not launching from start menu.

It will probably be these two or one of them that is missing and needs to be installed

libgcrypt11: this might help me and you if its what causing the issue.

You would have been better to post your ‘how to’ in the area… threads (due to age will be closed) and added references back to these threads…

Consider re posting to above since this thread refers to 13.2 which is EOL, for now the thread will be closed…