Can't install: Something is wrong with the YaST user interface


I tried to install OpenSuse 11.4 KDE on a Toshiba Tecra R700. First, as mentioned in few threads, I’m led to a login screen that won’t let anyone go through. I succeeded going it by using ‘linux’ as user and ‘’ (empty) as password in IceWM, logout, then login to KDE Workspace. I don’t know if one could login directly to KDE Workspace instead of Default right at the beginning.

Then I tried to launch the installation process by clicking on the icon ‘Install’ on the desktop. The window barely appeared, then disappeared, like a flash. I tried to launch it by command line:

linux@linux:/sbin> yast2 live-installer
./yast2: line 30: ./lib/YaST2/bin/yast2-funcs: No such file or directory
./yast2: line 298: set_lang_from_sysconfig: command not found
./yast2: line 195: check_qt: command not found
./yast2: line 198: check_gtk: command not found
Qt GUI wanted but not found, falling back to ncurses.
./yast2: line 327: check_ncurses: command not found
package yast2-gtk is not installed
Something is wrong with the YaST user interface.

Is OpenSuse installable on my machine?

  1. Toshiba hardware in notoriously difficult
  2. Did you run the media check function to make sure you have a good burn of the iso?
  3. Did you run the checksums on the iso file to be sure you had a good download?

Hi gogalthorp,

The CD was fine. I didn’t know how to check the iso, so I downloaded it again. I tried to install again, and everything is functioning.


Instruction to find the checksums are on the download page.

Glade you got it to work some Toshiba hardware can be difficult.