can't install simple packages - irritating!!

OK, I’m used to Ubuntu, but the latest version won’t install on my computer because of some problem with the CD-ROM driver…

So, over to OpenSUSE KDE. Very pretty, but…

I need Truecrypt and GRASS GIS - now, I’ve had both these working in Ubuntu no problem, but I’m now about to throw my computer out of the window!!

Tried this:

TrueCrypt - Free opensource on the fly Disk Encryption tool | SUSE & openSUSE

… so far as I can tell, these instructions must be incorrect. It just won’t install the package.

GRASS GIS - none of the RPMs will install due to dependency issues - and there are no instructions anywhere as to how to resolve them.

Microsoft will continue to rule the roost until LINUX developers find a simple and convenient way to install applications. I know that’s a standard noob complaint, but installing applications should not be difficult. I’m not new to LINUX and certainly not new to computers, but this is just a pain in the a*s! If I struggle to do it, the average user will have no chance whatsoever.

Any suggestions? Anyone know how to make either of these applications work in OpenSUSE 11??

EW

what happens when u install and what fails??

I think there is a formatting problem. the “–install” is formatted as “-install”. Try using “-i” instead of “-install” as in the article and let us know

Hmm, thanks but I’m getting nowhere. The archive downloaded from Truecrypt contains

truecrypt-6.0a-setup-opensuse-x86

with no .rpm extension - it’s not even clear what it is! It took about 5 milliseconds to get it working in Ubuntu, this is just a pain! Can someone just tell me in simple, idiot’s terms, what I have to do to install this simple little app?

I think the best thing to do might be to give up - I’m developing a new affection for Windows!

The link you posted reports links to 10.2 and 10.3 repositories. Try the build service instead. At this address there is the opprtunity to install it via the ’ one click install’:Webpin

Checkout 1-click install for opensuse 11.0

http://software.opensuse.org/ymp/security:privacy/openSUSE_11.0/truecrypt.ymp

click it, opens yast and its simple wizard to complete installation

> Microsoft will continue to rule the roost until LINUX developers find a
> simple and convenient way to install applications.

perhaps you had one minute of pain until you learned how to do the micro$oft
way, or Ubuntu…

let me suggest that instead of being frustrated because the ways you do know
don’t work here–take a little time learn all the ways that do work here…

like, have a short read on Basic openSuSE concepts at http://tinyurl.com/66h4rw
by clicking on “4 Software handling in openSUSE (Package Management)” where you
can become familiar with and PICK the way which YOU find “simple and convenient”…

free software is a lot more that JUST no/low cost…it is also freedom to pick
your way!

and, don’t forget a GREAT place to begin your search for software:
http://packages.opensuse-community.org/

where, if you type truecrypt into the blank, SELECT your version of SUSE (which
you didn’t tell us, but the way) and click on search…you will find a one click
install button…

seems simple to me. (but, i prefer a different method…zypper for some, YaST
for others, and even split an rpm or compile my own at the command line from
time to time–just for the nostalgia of it…


DenverD (Linux Counter 282315)
A Texan in Denmark

Yes, I like the one-click thing, but it doesn’t get me very far with GRASS GIS.

I’m really really wanting to move to LINUX on a permanent basis, but recent experiences have not been positive. The latest version of Ubuntu won’t install because of some strange bug that causes it to react badly with certain SATA CD-ROM drives (particularly irritating because earlier versions were fine, and I like Ubuntu!), and OpenSUSE harks back to the days before Ubuntu when you had to configure ntfs-3g manually, and installing software was a serious pain. I found it difficult and I’m a geek - what chance would my granny have?!

It’s not that strange to expect to be able to download and install software via binary installation packages, and I would think most people would expect an OS to read and write to all partitions from the outset. Ubuntu is a step in the right direction, but this year’s offerings are buggy as hell!

EW

I have installed all i need on my Linux systems until suse7.3. I agree that i had to solve a lot of problems. And i agree with DenverD. There are several ways to install software, simply you have to change your mind. In particular Truecrypt installs easily and works very fine. The idea beyond Linux is a little bit different: knowledgement has to be free! Otherwise only who can pay a lot of euros could write a document, for example with office. This in assumption that we all have legal software. Just an example: two or tre days ago amsn (a clone of msn) stopped to work, because i read tha m$ decided to change the protocol. In few hours it has been fixed. It was possible because this is open source. Actually i think that none HAS to switch to Linux by assumption. It is free (as in beer rms). If one does’t want, well it’s on he’s own. And about the hardware. Don’t you think that a lot of companies are constricted to release stuff only compatible with windows? I have also two macs at home, and you could not imagine the troubles when i get new hw.This is only my POV.But at the times of the campus everything was open source, but not Unix. Having Linux to me was like touch Heaven. And at the end os11 reads and writes all human kinds of file systems. My pc is multibooting Vista, Solaris, os10.3,os 11 and macosx86.

OpenSUSE can take a bit of learning to get used to.

One of first places to look for software is in the OpenSUSE Software Search (as stated above). This can be more useful than meets the eye. In bold, you’ll find the name of the package and below it, a simple description of the package (you can also press [more] for further descriptive information on the package). Below the description, you will find the .rpm files for manual installation, including the source .rpm file. On the right side, the gray text is a link and path name to the repository that is providing the package. Below that, if you wish to use the most simple method of installing software, is the 1-Click installer, which adds the repository (and can remove it after the application is added if you wish) and installs the application for you: all you need to do it enter your root password and press “Next” a few times. It is that simple to install packages through the 1-Click installers. The last link is the “Go to OBS Project” which will allow you to see the OpenSUSE Build Service that pertains to that package. Now that we covered the software search, let’s look at the package managers themselves to get a better understanding of the process.

The graphic interface version of the OpenSUSE Package Manager is YaST2 Package Manager. To open YaST Package Manager, open the application window for your desktop environment and enter “yast” into the search field. This will limit the applications shown to only those that are related to YaST. Click on the icon for YaST and enter the root password when prompted. Under the “Software” heading, you will find “Software Management” (as well as “Software Repositories,” which I will touch on a in a moment). When you open the Package Manager, you will be shown a list of software available for installation. You can enter a search term into the search field to narrow the packages shown to the ones your are looking for. The one thing to keep in mind is that this only shows the software available from the repositories you currently have available. So, if you are looking for a package, try searching the Software Search page (linked in the first paragraph), open the repository link and add the repository to YaST so you can search for more software. NOTE: make sure repositories are only added if they are for your version of OpenSUSE. Example: it is a bad habit to add Factory repositories on an 11.0 system or an 11.0 repository on a 10.3 system. In case you are unsure of how to add a new repository, refer to the following:

Adding a Repository:

  1. Open YaST
  2. Enter the root password when prompted
  3. Open “Software Repositories” under the “Software” heading
  4. Wait for the repositories to refresh
  5. Click the “Add” button
  6. Select “Specify URL…” and click “Next”
  7. Enter the URL of the repository
  8. Name the repository in the first field
  9. Click “Next”
  10. Click “Finish”
  11. Agree to import any keys if asked to (unless you have a specific reason not to agree)

The other version of the package manager is the terminal version: Zypper. To save some time explaining a long list of Zypper commands, this is a very useful page when learning how to use Zypper: OpenSUSE Wiki Zypper Usage page. Because Zypper is used through the terminal, it can be much easier to find specific topics or software through the commands, rather than searching through a GUI to find what you are looking for. For more information on Zypper itself, try this page as well: OpenSUSE Wiki Zypper page navigation.

Now, address your package issue. Below are the 1-Click installers for your packages:

That should make installing those packages much easier.

I know that learning the basics of OpenSUSE may be frustrating, but after getting a hold on the basics, it is much easier! So, hold in there. :slight_smile:

If you have any more questions, feel free to ask.

Hope that helps you! :slight_smile:

earwicker.

Start here: Add Package Repositories to YaST - openSUSE
setup your repos: Package Repositories - openSUSE
especially oss & non-oss.
and
Additional YaST Package Repositories - openSUSE

Then tell Yast > Software Management to install kernel-source, kernel-syms, gcc, make & C++ and you won’t ever have a problem again

Then install “whatever”.

Thanks guys, that’s clarified things! Unfortunately the computer I run Linux on isn’t connected to the Internet, so I have to keep hauling it downstairs and hooking it up to the router (unplugging the one that’s normally connected etc.)! I had quite a tiring and frustrating day yesterday!

All particularly annoying because I’m open source/Linux’s greatest fan, it’s especially annoying when it rears up and bites you on the ass! That installation/CD-ROM problem with the latest Ubuntu in particular was exceptionally irritating - exceptionally!! I’ll give it another go when 8.10 comes out.

OpenSUSE is quite cool though. It does certainly seem to lack Ubuntu’s user-friendliness, although I suppose one could argue that said user-friendliness simply comes from the fact it apes XP in certain respects. But at the end of the day installing apps on it from a flash drive and reading/writing to all partitions, including NTFS, from the outset, is a major boon; this year’s remarkable crop of bugs, however, are a bane!

Nice, anyway. A bit on the green side, but that can be changed. I don’t think it’d hurt to make it a bit more intuitive - I’ve used Ubuntu off and on for a couple of years now, but I still found OpenSUSE very fiddly.

EW

If you want to make an offline installation just download the whole link that me and another user posted here. Maybe you have another pc hooked to the router. Then add this directory you download to the local repos in yast so now you can install truecrypt from there. I advice that this way could be dirty. I mean that it could require extra dependencies you can’t satisfy at the moment because you are offline. Write then and download them also. Or compile the package on your own. Make sure that you have installed the development tools especially make and gcc because those are not installed by default

I had the same problem installing trueCrypt on opensuse 11.1 and was also very frustrated for an evening. This is what I did that worked:

downloaded trueCrypt from TrueCrypt - Free Open-Source On-The-Fly Disk Encryption Software for Windows Vista/XP, Mac OS X and Linux - Downloads

uncompressed file. This left me with the same file:
truecrypt-6.1a-setup-opensuse-x86

next I executed the file, which then showed some screens and created the truecrypt-6.1a-0.i586.rpm file.

Then:
su
yast2 -i truecrypt-6.0a-opensuse-x86.rpm

The problem I had in following the instructions in the link:
TrueCrypt - Free opensource on the fly Disk Encryption tool | SUSE & openSUSE

was that I didn’t realize that I had to execute the file in order to extract the *.rpm file.

Once I realized that, it was easy as pie.

I hope this post helps someone.

My thanks to all the opensuse developers. Despite occasional moments of frustration, I really like this OS. Way better than windoze…