can't install screen scrambled

Got a problem when trying to run the KDE-LiveCD (and install). It boots just fine but when X starts (or whatever it is) I get a scrambled screen (image below). I’ve tried to boot with all kinds of different settings. VESA, Safe settings, ACPI OFF. etc. it just doesn’t work. (text mode works fine)

I’ve had this problem on other distros as well. Some distros work (fedora 11 for example), others don’t. This problem started maybe 1-2 years ago.

dmesg shows nothing special (what it looks like to me)


my system:
AMD 64 2000+
Nvidia GeForce 7600 (AGP)
MB Asus K8N

What happens if you boot in text mode and start X from there?

Fast reply! :slight_smile:
startx gets me nowhere. X (probably) starts but my monitor shows a “out of range” message Same when I try to boot with the VESA-option. It’s a flatsceen connected with DVI(does that explain why VESA failed).

ctrl+alt+backspace throws me to a blank screen with a blinking cursor and I have to reboot.

Did you already try to configure X with sax2 ?
Assuming it doesn’t help, if X works under Fedora, can you get a /etc/X11/xorg.conf from there and use it under openSUSE? Fedora 12 uses the ‘nouveau’ driver, but Fedora 11 might still use ‘nv’.
Also did you try to install the nvidia proprietary driver?

If your monitor is broken and sends wrong information about its frequencies, you might have to use the option IgnoreEDID in /etc/X11/xorg.conf and set HorizSync and VertRefresh manually. It sometimes solve “out of range” issues.

Also does it work every time in Fedora 11?

I am only running the liveCD. Seems like it is a little bit to shaky to install without X working (sax2 doesn’t work in liveCD).

About the monitor: I have Fedora, ubuntu (8.04) and Frugalware (2 year old release) installed. All function with dualscreen setup, flatscreen and fat-TV with DVI–>hdmi (yes they exist :slight_smile:

When writing the above I realized that the TV could interfere, Tried to boot again with it unplugged. Now it fails with a blank screen (no signal input) instead of a colorful scrambled failiure. :slight_smile:

Hitting ctrl+alt+backspace blinks the screen, then “no signal input”. hitting ctrl+alt+backspace takes me to a console. startx → blank screen.

Had an old ubuntu 8.04 live-cd laying around, works fine. same with ubuntu 9.04. Knoppix 2010 is not working, same error. Just tested Suse 10.0 (!) and it gets to the graphic installer before I abort. (yes I have a gazillion old distros laying around. :slight_smile:

Anyway, it seems like something relatively new introduced in a couple of distros is not compatible with my system. Question is how to fix it.

I’m running 11.2 on my laptop and I really like it, want to use it on the troublesome desktop as well.

You should be able to run sax2 from the command line as root and it should create a xorg.conf file, but it will of course not be permanent. It should tell you if you can do the install and boot to a GUI

sax2 -r -m 0=vesa

Since you had 2 monitors you may need to switch the cables around. It may think the plugged one is in video slot 1 instead of 0.

sax2 -r -m 0=vesa

did the trick. :slight_smile: all low bit color and low res. but hey it’s a GUI :slight_smile:

Pretty sure I can manage it from here.

Thanks guys.

Once you get the OS installed you can install the NVIDA drivers for a much better experience. vesa is very generic so is limited.

NVIDIA drivers - openSUSE

Yes! That I know how to do. At least before they took away xorg.conf (which I can write from scratch for a dualhead setup if necessary) :slight_smile:

Thanks for the link!