Can't install rhythmbox

Hi i have just upgraded my system to Tumbleweed (gnome 3) and everything went smoothly, however when i try to install rhythmbox or sound-juicer i get an error “rhythmbox-0.13.3-5.1.x86_64 requires, but this requirement cannot be provided”
Then i get an option to downgrade gnome-media from version 2.91.2-1.2 to version 2.32.0
Is it safe to downgrade gnome-media or is it needed by gnome 3? or is there another package that provides this that i am missing?

I have the standard openSUSE repos 11.4-oss, 11.4-non-oss, 11.4-updates and packman-tumbleweed, tumbleweed-standard and tumbleweed-gnome


Although I don’t know for sure, I guess it would’t recommend it to downgrade it while it is needed by gnome 3, so I would have done it. But again, this is just my guess

I don’t have Gnome or Rhythmbox, but I notice there is a more recent version of Rhythmbox in this repo:
GNOME:Apps/openSUSE_11.4 located at xxxx://

Might be worth hooking that repo on for a test of installing Rhythmbox. (wild guess really).

Thanks for your replies, I have tried installing Rhythmbox from that repo and from Factory as well but they both give the same error, but I did solve my Sound-juicer problem by installing Grip instead.