Can't install properly

I am using OpenSUSE 11.1 DVD, yes I checked the checksums. DVD boots fine.

  1. Tried it on a couple of Thinkpads (T40p, T61) and failure. One said something about can’t load the volume partway through install or something. I gave up on those. (Yes, I read the Lenovo specific issues). FYI, Ubuntu 8.10, OS X, OS/2, WinXP all installed fine on those machines.

  2. Standard desktop. Intel D946GZIS motherboard with Core 2 4300 and 1 Gig RAM. nVidia 7600 video card (ASUS). This one actually makes it through install but with various issues:

  • Install hangs if on-board sound is enabled.
  • I have dual monitor, but install always detects the wrong monitor. The monitor it thinks I have is then screwed up, while the primary monitor (which it detected wrong) actually displays fine.
  • If install with KDE 4.1 as default, eth0 is never created, so no networking
  • If manually create eth0, network is always broken when I login with KDE 4.1. If I login with GNOME, set it up again and reboot, network is fine (wired connection).
  • If KDE 4.1 is default login, and I ask for reboot of machine, it always takes me back to the login where I have to ask again for reboot. Not the case with GNOME login.
  • If install with GNOME as default desktop, I get the GNOME login, but usually the prompt for password doesn’t come up! Sometimes I right click on the user and I get to enter the password and login. Most times, there’s nothing so login fails (says wrong password. DUH! of course if you don’t let me type it in), and then it effectively hangs while trying to re-try or something.
    ==> This is my development machine. It is solid with the WinXP drive plugged in. It’s also good with Ubuntu or KUbuntu.

So … what am I doing wrong?

Sorry to be pissed off, but this experience so far has just SUCKED. (FYI, I’m hardly a computer newbie. I’ve been using Linux since the RH 3.0 days and my day job right now involves writing Linux drivers for our embedded systems). These are very common, standard machines I’m using.

I am very suspicious of your installation DVD. Sometimes things can go wrong with an installation DVD, even if the checksums pass.

I’ve installed 11.1 on 4-systems thus far. The hardware was significantly different in each case. No problems. Sound worked in all cases. No such freezing as you have reported.

I am very skeptical that it is a DVD problem. Really? That flaky? Open Solaris never had that problem, nor did OS X nor 4 versions of Ubuntu/Kubuntu or eComstation|OS/2

Anyways, just in case, I downloaded a new copy, this time of the KDE Live CD.

  • First time, ALL sorts of errors with SquashFS and the install just hung there. Second time, it “booted” to the desktop at which point I clicked on “Install” and let it proceed. (Still sound card is disabled, just in case).

  • On reboot, the desktop came up fine. Monitor is still screwed even though I connected only my primary monitor via DVI, no secondary this time. Aside from that, whaddya know, network is up, everything is running. Happy, right?

Well not so fast buddy! The notification of system updates popped up, so sure, okay, I let it do its thing. Only it fails. So I try again “manually” like it suggests (which really just lets you see the details). It runs off to fetch some updates, but there’s a handful of packages that fail to get. Why? My network connection is fine cause it gets everything else and it’s all on the same server. So either someone moved around the packages or something else is messed (NEVER had this problem with Ubuntu). Regardless, I let it finish and reboot.

Wowee. No surprise, I get no network. Yes “eth0” is there, but for some reason fails to get connectivity. At this point, I’m pretty much fed up with OpenSUSE, so I’m not even going to bother trying anymore… I mean, this is as standard a system as you can get in terms of hardware.
Even OpenSolaris came up fine on this machine! Geeze! You can’t even blame it on Linux since Kubuntu with KDE4 went okay too.

OK, then enjoy your OpenSolaris or your Kubuntu.

I view Linux as Linux, and IMHO users should stick with the Linux that works best for them.

In my case it is openSUSE. Ubuntu are notorious for not passing their fixes upstream, so I refuse now to use their products (for that and other reasons). As noted, openSUSE works fine for me, and for over a dozen people I have exchanged email/PM’s with. But sometimes one will have hardware that does not cooperate, or one will always follow the same systemic approach that prevents a successful install.