Cant Install OpenSuse

So i wanted to try out OpenSuse but i think the Operating System doesnt really like me. Ive tried to do a bootable USB with Etcher, RosaImageWriter, Suse Image Writer and Image USB but none of it helped. I always get a purple, red or blue Screen when i try to install, check the memory or anything else. I dont know what to do and i would appreciate any help very much!

if its important, my system is:
Gtx 970 4gb
16gb Ram

Try with:

dd bs=4M if=/path/to/dvd.iso of=/dev/sdx status=progress oflag=sync
Where sdx is your USB stick.

you mean into the additional boot commands tab? well i cant even see it because it seems that it doesnt scale very vell with my Monitors. on my Laptop i can see Options like F1 Help and such but on my PC its cut off for some reason, i have 2x 16:9 1920x1080 Monitors but also tried to disable one.

Write the ISO with this command.

This is probably an (U)EFI system, in which case those options are not displayed for technical reasons.

Try to press ‘e’ at the boot menu and append “nomodeset” to the line starting with linuxefi, then press F10 to start the installer.
This will use a generic fallback video driver and should help if it is really a video issue.

to the previous answer: i cant write that because im currently using Windows.

now to wolfi323, yes it is a UEFI system but i dont know exactly what you mean. My Motherboard is the x99a Raider model and i didnt found anything about a nomodeset in the online manuals nor do i know where such a line should be.
I feel really ashamed to be such a newbie but i have no clue about hardware, software alone yes but never in combination with actualy hardware and ive never tinkered around with my bios.

Quick Update: pressing E did nothing.

ok im very very sorry. it did work. i just didnt knew where. For all who are like me, boot up the USB drive and then press E. Thank you Wolfi323!

if used on usb sticks the opensuse installer needs to be written in dd mode

dd bs=4M if=/path/to/dvd.iso of=/dev/sdx status=progress oflag=sync

is a linux command that copies files
as you are on windows and have no access to dd you can use rufus (it’s an opensource project)
after selecting an iso image you should be given a choice between writing to usb in iso or dd mode or you can select dd mode and then search for the iso file (which might be hidden as rufus expects only img files in dd mode)
also you should check that safe boot is disabled in bios and fast boot is disabled in windows as fast boot is a hybrid hibernation it does not shutdown windows fully and might cause issues when installing/using a 2nd OS

Yes, that’s what I meant, press ‘e’ at the installation medium’s boot menu (where you can choose between “Install”, “Upgrade”, “Boot from Harddisk” …), not the BIOS/EFI menu.

Sorry if I wasn’t clear enough.

Btw, AFAIK the installer will take the “nomodeset” option over to the installed system, so it may be worth a try to remove it again afterwards.
You can do it via pressing ‘e’ at the boot menu again when booting the installed system (just remove “nomodeset” now instead of adding it :wink: ).
This won’t get saved though, which also has the advantage that you cannot “break” your system.

You can do a permanent change in YaST->System->Boot Loader->Optional Kernel Parameter (or something like that).

The “nomodeset” will prevent the proper graphics driver to be used, and normally only makes sense in case of problems.
Leap 42.3 comes with backported kernel drivers from Kernel 4.9, but IIANM those are not used by the installer. So it may just work after installation. If not, feel free to ask with more information about the problems and your system (what graphics card/chip at least), preferably in a new thread.
Especially those new kernel modules may cause problems on some (mainly older) chipsets, so the first thing to try would be to uninstall the package drm-kmp-default in case of problems.