Can't install OpenSuse on an Alienware Area-51

I’m trying to install OpenSuse 13.2 on an Alienware Area-52 machine, but I’m not getting very far. It hangs at the message

Starting udev...

Anyone have any idea what’s going on, or how I can get OpenSuse installed (it’s hardly begun the process at this point).

I did have problems insalling OpenSuse on a previous Alienware machine because of its cutting-edge technology, but that was solved when OpenSuse 13.1 came out. Area-52 isn’t a new product and 13.2 should be able to run on it.

Why are you trying to install 13.2? The current versions of openSUSE are Leap 42.1 (annual release) or Tumbleweed (rolling release)

Both are significantly newer than 13.2, which was released in 2014 and will reach end of life in about 1 years time.
It looks like some kind of hardware compatibility issue, but that’s one of the main features we bring in each new version, I’d expect Leap 42.1 will work much better with hardware which 13.2 balks at.

Thanks. Leap 42.1 did work.

I don’t know why I didn’t notice that this was the latest version when I checked before. I think I must have just been looking for an release marked ‘openSUSE’, and I failed to read the small print!

However, having installed Leap 42.1 my PC is still loading Windows unconditionally instead of offering me the Grub menu. Any ideas on what’s gone wrong here?

Added: The BIOS is set to UEFI Boot. Is this the problem, and, if so, what do I do about it?

Is this a UEFI box? If yes, then was opensuse installed to use UEFI booting or legacy booting? Does Windows use legacy booting or UEFI booting?

It is a UEFI box. It looks like it’s a Windows 10 / UEFI problem, as far as I can tell from a search though this forum.

It looks to me like the best option is to delete Windows and run it as a purely Linux machine. The only problem with this is that, if I need Dell to do ant maintenance, they only have Windows programs. I’m trying to create a recovery disk now so that I have some insurance if I delete Windows.

I’m reminder of something I saw recently: Fifty Shades of Nerd - a parody of you know what:

“You’ve been a naughty girl,” he whispered in her ear. “I’m going to have to punish you.”

So he installed Windows 10 on her PC.

Problem solved! So, for the record, what I did was:

a) Used Windows 10 to create a Windows 10 .iso file, which I copied to a removable disk and thence, via the laptop I’m using now, to my sysadmin folders in Dropbox, along with a text file containing the product key. I then used this laptop to burn the .iso file to a DVD (Windows 10 does not appear to come with a DVD-burning program.

b) I then installed Leap 42.1, taking the “Use the entire hard disk” option, thereby removing Windows.

I can now boot up openSUSE (and, indeed, reboot it). I am also at the point that I was planning on being some 24 hours ago (okay, so I had a few other things to do - but, nonetheless…) if there hadn’t been this bug (or feature?) in Windows 10.

I’m hoping I’m not going to ever need, say, a BIOS upgrade on this machine. Dell can only upgrade a BIOS by running a Windows program.