Can't install Opensuse 13.1 on Dell Inspiron 15R (7520) BTX Base

I bought this laptop nearly 1 year ago. It came with win8. Updated it to win 8.1.
I finally got around to install Opensuse. First, from win8, I shrunk a partition to create space for Linux,
as I had done in the past on win7 machines.
I downloaded the iso image for the 32 bit version and burned the DVD.
I put it in the laptop turned on, nothing, just booted win8. I found the boot options by
pressing F12. There are no options to select the booting device, only stuff to disable
UEFI. After trying a few things, I found this guide :

I did not back up win8 stuff but I did follow Part4, section4 (unselect “turn on fast…” etc.)
I then selected legacy mode (disable UEFI and secure booting). Laptop tried to boot from LAN. Pressing ESC
makes it stop and boot from DVD. Great! Suse install comes up. Follow through etc. Select packages etc. All looks ok.
I then get to the part 5, section 9 of the guide above : if I select the Booting Options there is ABSOLUTELY NO
MENTION of UEFI, it looks nothing like in the guide. I can only select GRUB, GRUB2 or LILO, no sign of UEFI awareness.

If I continue, the install proceeds, the machine reboots, but, if I select “boot from HD”, i get an error message that
there is nothing to boot from, if a I press a key, it re-loads the DVD iso. If I take off the DVD, I get the same message
and nothing to boot. If I re-activate UEFI secure booting, then win8 reboots, but Suse is nowhere to be seen.

No idea what to do next.

I only have time for a quick comment as of now, but I’ll look into it again tonight (which would be in 6-7 hours from now).

Provided you made no type above, you started with the 32 bit version of 13.1 which doesn’t support EFI nor secure boot. Windows 8 (and 8.1) both requires EFI activated and 64 bit, in addition they both come preinstalled with secure boot activated (but you are free to disable it). I do, however recommend you keep the secure boot active. It does serve a purpose. Later on, if you find a reason NOT to have it active, you can always disble it.

So, you need to download the 64-bit full DVD installer and use that for installation. I have never tried installing 64-bit on top of a 32-bit installation, but in my mind that should proceed pretty easy, so I think it’s worth a try. See how it goes. You can follow my how-to using 13.1 in place of 12.3, but 13.1 need no particular attention to the secure-boot-tick.

If you have the bandwidth for it, I would recommend to download the 64-bit Live DVD as well, and give that a spin before you install. Try it out, and see what happens (but do the install from the proper Install DVD!). If you do, you have a pretty good idea about how things will work out. The only thing you will not be able to test here, is the EFI-install part. If that proves to be a problem, post back here and we’ll try to help you out.

Good luck!

Until later


Thanks, I confirm it is a 32 bit install of Opensuse. Can the 64 bit version run stuff previously compiled for 32 bit ?
I vaguely remember that I had some problems in the past with 64 bit version but that was ages ago.
I’ll download the 64 bit version.

Depending on what stuff (all openSUSE packages are 64 bit ) You may need to install 32bit versions of certain libraries. Running 32 bit on 64 bit OS is generally not an issue.


I downloaded the 64 bit iso image and it worked. The DVD still would not boot but, pressing F12 would get to the boot
options and, this time there was the DVD. Everything went well with a couple of problems :

  1. During the first reboot the machine asked some question on peripherals to activate and got to “Starting Yast2” and then
    did nothing for quite a while. I turned t off. When on again, it said the installation had failed but I could continue and it
    could ask me again some questions. It basically repeated the same questions. This time Yast2 didn’t stall, and all seems well,
    but not sure if I should trust it.
  2. Previous 32 bit test installation had 2 GB swap and the rest available to Linux. I wanted to change this but I could not. If I select
    the swap partition, I can only shrink it. Previously I used to shrink the main Linux one of the same amount I wanted to grow
    the swap partition, delete the swap partition, re-create it larger. I could not find a way to create a partition. All I get is
    Edit, Resize, Delete and another option I forgot. Nothing like “ADD or CREATE”. Swap was in /dev/sda8 . I haven’t used this
    for a while, but I’m sure it was easier before.
  3. This is minor, but, since I’m here, I might as well ask. Opensuse install assigns the name to the machine. Is there a way
    to chose your own name ? I could not see it.

Since I haven’t started using Linux yet, I’m happy to do it all again, especially to fix 2).


When changing a partition size you must have space to expand into ie if another partition is right next to the partition in question you have to move that partition to allow for expansion. Partitions must be continuous

I also try to shrink the Linux partition first. The Linux partition was on /dev/sda9 ~388 GB. I resized it to 384 GB, but when I got to resize the swap partition, the max was still 2 G. Swap partition was /dev/sda8. They appeared contiguous in the list. They were created from the same area I got when shrinking the win8 partition from win8 itself.

I think I understand now. I need to resize the Linux partition (make it smaller), move it, then expand the swap one.
I’ll try that.

oznelig wrote:

> Thanks, I confirm it is a 32 bit install of Opensuse. Can the 64 bit
> version run stuff previously compiled for 32 bit ?
> I vaguely remember that I had some problems in the past with 64 bit
> version but that was ages ago.
> I’ll download the 64 bit version.

Given the steps you have already tried, I would suggest that you essentially
start over. My personal experience is that the install of 64-bit over 12-
bit doesn’t really get you a clean install - there seem to be odd bits and
pieces that eventuaLLY BITE YOU.

As for you problem expanding swap, you are running into a physical mapping
problem - when you recreated the Linux system partition with the initial
swap partition in place, there was no contiguous space left for the enlarged
swap. Delete BOTH swap and system partitions. Don’t touch the Win and
original partitions like efi or EFI and probably a couple of win-related
recovery partitions - just remove the Linux swap and system partitions.

If you have secure boot enabled in the BIOS, the DVD should show up in the
boot menu.

Will Honea

note also if you intend to use secure boot you should tick the secure boot box even if secure boot is not active when you install.

Thank you to all the people that helped.
I managed to get the iso 64 bit image installing without problems aside win8.1. Now the machine is dual boot.
I also managed to expand the swap partition by deleting the Linux partition, resizing the swap and re-creating it.
This did caused a temporarily problem because the mount point was no longer boot/efi but another iteration
of the install fixed that too (it found the existing partitions and set the proper mount point).
I did not see how to change the machine name in the installation, but I believe that is possible to change
afterwords and if, not, I don’t really care.
Next to try is to mount the win8.1 partition to transfer files across.

I apologize. I was prevented from returning in the promised 6-7 hours. (Actually, I thought it would be solved in 2-3 hours, so doubling it would buy me some time left-over. Not so - it took considerably longer. It was a matter of making HW working with Windows XP and where updated drivers are unavailable, continue working now that WXP is declared extinct. Then there were some ‘while you are here’ issues… ). Again, I apologize. However, it seems you experienced the good thing about openSUSE forums - there are many knowledgable contributors here. They helped you achieve what you wanted already.

Also, I forgot say in my previous entry: Welcome to the openSUSE forums!

There are several ways to achieve that. The easiest way is to edit /etc/HOSTNAME (that’s the 12.3 position, I expect it to be the same in 13.1, but I can’t check that while writing this), then reboot.

You need to be root to do that. Make it a habit to issue “su -” (note the dash) from a terminal when you want to become root, then start your editor from there. That will keep root-usage from messing with settings you made for your standard user, and you (as root) are free to use whatever application. (You can also use “sudo <command>”, but sudo do have some limitations I do not want to be bothered struggling with, so I have made a habit of using “su -”. In my view, the dash-thing is what makes using “su” trouble-free.) Alternatively, if you’re using KDE, you can select “File Manager - Super User Mode” from the menu, select the file you want to edit and send it to the editor from within File Manager.

However, I’ve grown accustomed to another way of renaming my Linux computers: Almost all the Linux computers I’ve set up - dual-boot or not - needed network adapter adjustments. (Yast -> Network Devices -> Network Settings). While in there, you’ll see a tab called “Hostname/DNS” in which there is a field called “Hostname”. You can change the hostname there, and Yast will make the corresponding changes in /etc/HOSTNAME for you (or the proper ‘elsewhere’ if I’m wrong in assuming 13.1 use the same location).

I guess you already solved that one by yourself: You need to be root to do that.
But beware while doing that, Windows must be in a completely powered-off state. If not, portions of the files are stored elsewhere than in the standard NTFS tables and modifying files in the NTFS system could corrupt the NTFS file system. Also, merely reading files from NTFS in such a situation, would give you unreliable results. In such situations, since only some files are stored elsewhere, degugging and making sure what state which files are in, can be difficult.

If you properly did what I suggest in my how-to ( Part 4, item 4.7, you should be properly prepared for working with NTFS from Linux.


I did 4.7 and I was wondering whether to revert to the original setting now that’s all installed, but I saw this posting and I understand that’s best left fully off if one is to mount the NTFS partition. Speaking of which, I did try briefly but I did not succeed. I’m currenty busy with other priorities but I’ll come back to this soon.
Anyway, thanks again.