Can't install opensuse 12.1 from DVD, installer can't find DVD devices?


I have an HP pavilion dv7 laptop (3 years old) with Windows and Linux mint in a dual boot mode, and I wanted to install opensuse 12.1 from a DVD over my mint partition.

When I boot with the 64bit KDE live CD in my DVD I can get to the menu where I can choose to try the live session or install.
If I choose either, I see the linux kernel loading successfuly, then a green screen with opensuse logo, and after about 10 seconds the screen becomes a black text screen, and I see an error message saying that my DVD device wasn’t found, and that the system is restarting in 120 seconds.
I tried alt+f3, alt+f4 but it didn’t make much sense to me. I think saw something about MBR not being found.

My laptop doesn’t have any issues (DVD works perfect). what could be causing this? should I just try to re-burn the installer on another DVD?
I managed to install Linux Mint with a live CD just two days ago, but I really prefer opensuse :slight_smile:


Did you run the media check?

Thanks for the quick reply!

Haven’t tried it. I’ll do as soon as I get back from work.

I tried the media check, but it failed to start exactly like when I choose to install or try the live CD.
I took a picture of the error message, and the output of alt+f3,alt+f4, but it seems like I can’t inset attachments here.

the error message basically says that its checking for CD/DVD devices and not finding them.
Then it says “couldn’t find live image configuration file”, and it gives a rebootException.

You could try this

Can you use another machine to do the media check?

I have another HP laptop similar to my own, the live CD works there perfectly.
I’m starting to think the problem is related to my linux mint installation and grub2. Is that possible?

I’ll give the text installation a shot.

I’m starting to think the problem is related to my linux mint installation and grub2. Is that possible?

No. I doubt it very much.

It’s more likely hardware related.

If text mode doesn’t get you there. Then 12.1 might not be for this machine.

Well, I couldn’t get around the DVD issue.
In the end I managed to install opensuse 12.1 from a USB, and it works perfectly (even DVD is recognized).

Odd, but I don’t mind since I got it to work. Next time I’ll try the USB first, it’s much faster than a DVD install!
Thanks for the help.

It may very well be the drive in the laptop. Mine works on and off. Sometimes I can even burn data to disk, but most of the time I’m getting errors like you have when booting from it,

Good to hear of your success