Can't install opensuse 11.4 on notebook


Came into possession of my dad’s old hp notebook (HP520) and want to install some linux distro on it to use it for basic web browsing and word processing. After a bit of research decided to begin with opensuse.

Only problem i cant seem to install it on the notebook. The dvd drive is dead and hence i wanted to install suse through a usb drive (2GB). Downloaded the appropriate live CD and used it to make a bootable usb disk as per instructions on The drive boots up fine but no matter what i do i the next screen is always a black screen with a blinking underscore and nothing seems to happen. However compatibility reports indicate that suse should install hassle free and everything should work!

Already attempted text mode and safe settings installations. Nothing has worked so far. XP seems to run perfectly fine on it.

Here’s the cpu-z report for the laptop if that’s any help:

Thanks in advance.

The drive boots up fine

You mean you get the boot screen menu?

How much RAM do you have?

Yes i get the option to install, or use the live installation from the usb. However doing either will leave me at a blank screen after loading the kernel.

Ram is 512 mb ddr2.

Its possible openSUSE-11.4 does not like the Mobile Intel(R) 945GM/GU Express Chipset in that laptop.

Try to force the fbdev driver initially when installing. You can do that by typing ‘nomodeset’ (no quotes) in that very 1st boot menu that appears.](
[click on the above example for a larger view]

… its possible you do not have enough memory for a liveUSB graphic install ?

I assume its possible to do a text install from a liveUSB and if so, there may be sufficient guidance here: Text mode install from liveCD

Still no luck none of the methods gets me past the 2nd screen with the “Loading linux kernel” message.

The kernel will load to 100% and I get a black screen, cant input at all. The only way out is to restart the laptop.
The only thing that works from the boot menu is the memory test.

Same problem my laptop is MSI EX620 my video is mobility radeon 3470.

With a radeon HD 3470 you MUST use the ‘nomodeset’ boot code , or the Safe Settings selection.

I have laptop dell 1749 with ati 5650HD and nomodeset just allow to next step -> startup smartd and then frezee help!!!

Try booting with either the boot code ‘x11failsafe’ or selecting SafeSettings or FailSafe.

ok i will try this

still nothing, x11failsafe blackscrean kernel safe mod freez on ->startup service kdm4 help!

I confess that makes me suspcious of a bad installation CD/DVD. Did you conduct the md5sum on the downloaded .iso file and compare that to the md5sum posted on the download web site? Were they the same? Did you burn the .iso to a +R or -R (not an RW) at the slowest speed your burner allows (to a high quality media and not some bargain basement special) ?

Are you able to boot to run level 3 ? (full screen text mode) ? Is this an installed openSUSE or is this a liveCD you are trying to boot ?

I download suse 3 times and burn iso image(live CD) to disk and usb(with usb iso writner or something like that) and still nothing
if i dont type nomodeset blackscrean rightaway but when I typ nomodeset and pres ESC to se what is he doing he freez on startup smartd.
when go whit kernel safe mode he freez on startup service kdm4

The number of times one downloads makes no difference. No difference. What matters is it passes the md5sum check. What also matters is it is burned to a CD/DVD at the slowest speed one’s burner allows to a high quality media (and not some bargain basement special). And I have discovered CD/DVD RW’s are not so reliable for burning a Linux .iso and one is much better using a +R or a -R. Again, burn at the slowest speed.

To repeat, the # of times one has download is not important. What is important is the download is good.