Can't install opens use: doesn't support DPO or FUA

I got a workstation assembled. While installing open sues, it stops with this message
Z.647531] sd 3:0:0:0: [sda] Write Cache: enabled, Read cache: enabled, doesn’t support DPO or FUA

I have no clue what to do next. Please help…

aniva

That message is quite normal trying to access a SATA disk. A wild guess of why it stops there might be:

  • broken / dirty / not well inserted disk connector…
  • disk not formatted or partitioned yet
  • disk with no partition table / with a partition table not recognized by the default installer
  • UEFI enabled in the BIOS but DVD installer booted in legacy mode

I would suggest to boot with a LiveCD and see if hard disk can be accessed / formatted before attempting actual install, just to rule out HW problems like faulty connectors, outdated bios and the like.

Bumping this thread as I have run into the same issue.
This is on a brand new Asus ROG GL552VW.

Issue is the same with Live CD (on a USB) or with the full installation ISO on a USB.
I have already created partitions in Windows.

The machine comprises of 2 hard drives-
a 1 TB SATA HDD & a 128 GB M.2 SSD
The root & swap partitions are created on the SSD & home is on the SATA

Have created the bootable USB using Rufus.

Would appreciate any help.

The OpenSUSE iso images include a hybrid partition and are in general screwed up by Win USB burners.
The simplest way to burn an OpenSUSE image to an USB key is using dd on the command line on any Linux system, like


dd if=<your_OpenSUSE_image>.iso of=/dev/sdx

substituting /dev/sdx with the address of your USB key, e.g. /dev/sdc.
Please be careful, you will wipe EVERYTHING on /dev/sdx by this command, so be absolutely sure that sdx is really the USB drive you want to burn.
Also, don’t write the image to a partition, e.g. /dev/sdx1, but to the root of the device.

As an alternative, you can use “imagewriter” on OpenSUSE if you can access a computer with a working OpenSUSE (even a LiveCD will do).

Sorry, but I don’t know of ANY burner on Windoz that gives good results with OpenSUSE images.

Thanks for responding OrsoBruno.

I do have a mac, so created another bootable USB using DD command.
However, even with the re-created USB it hangs in the same stage.

Pic of the error:


I did a bit of searching online and added the following parameters:

i915.preliminary_hw_support=1 nouveau.modeset=0 acpi_osi=! acpi_backlight=native idle=nomwait

These overcome the previous issue, installation gets ready to start, but hangs while booting realtek drivers

Pic of the error:

I added

brokenmodules=r8169*

to the boot parameters, not sure if the code is wrong, but it did not help.

Do you have AHCI enabled in the BIOS/UEFI?

Best regards

susejunky

Yes… AHCI is the only option & it is selected

The module is called r8169 without any “*”; maybe it needs kernel firmware, there are several rtl_nic/rtl8168???.fw available.
I don’t really know if this might help you.
Good Luck!