can't install madwifi-kmp-default kernel

I just installed SuSE 11.0, and want to install a Netgear wireless card. I added the repo for madwifi using the one click install found on
I opened YaST → Software → Software Management.
Searched for madwifi.
The main tool package was installed as expected.
I opened a terminal, typed “uname -r” which indicates I have the default kernel.

When I click on the default madwifi kernel, the following error message occurs.

nothing provides kernel(vmlinux) = ef0147c0fae49e41 needed by madwifi-kmp-default-…

And, hence YaST will not allow kernel to install.

Any help would be appreciated.

Same problem using Zypper.

Yes, this is still a known (i.e. unfixed) problem, based on all the
other postings here in this forum. [Novell released 11.0 too soon,
in my opinion, as there are still problems such as this that remain
unresolved. Wireless, in general, has been a real mess, as has
KDE 4.0.4.]

You can compile from source (which I did), and that got it MOSTLY
working, but once I got the ‘ath_pci’ driver to work, I then still had startup problems
when I rebooted.

The only solution that worked for me was to use ‘ndiswrapper’, and
to specify ‘manual’ startup (aka ‘ifup’).

Details of ndiswrapper use are at:
Ndiswrapper - openSUSE

Hope this helps…


Check out this thread.

I did the following:

ndiswrapper -i netw51.inf
ndiswrapper -l
netw511 : driver installed
device (168C:0013) present (alternate driver: ath5k

When attempting to setup the device using YaST–> Network Devices → Network Settings
The tool indicates that the device is not connected. Editing the device → hardware shows the driver is ath5k, and not netw511. The netw511 driver does not appear as a choice, and the wireless card isn’t working.

I ideas on whats going wrong?

I have the almost the same problem, I have a HP Pavilion Dv6000 series and when I installed SUSE 11.0 It does not recognize my wireless. I put the WinVista 32Bit drivers and perform the ndiswrapper install.

But appears.

athr : driver installed
device (168C:001C) present (alternate driver: ath5k)

And … In YAST appear ath5k :frowning:

AR242x 802.11abg Wireless PCI Express Adapter (not connected)
BusID : 0000:03:00.0
… UKNOWN wlan device … see dmesg output

I have tried for a month …

Help me… I have heard about madwifi but I cant to perform the “make” because KERNELCONF: /lib/modules/ does not exist…

Please help me … I dont like Windows but I need internet :frowning:

Help me

Thank you!

If you have AR5007, AR58XB53, AR58XB63

Yast-Software-Software management, search for kernel-default, update kernel to 1.1 or 0.2.

Please follow instructions for Aspire 5720z.
HCL/Laptops/Acer - openSUSE

Your search must be done for madwifi-kmp-default.
Don’t use 1-click, just select suitable rpm, something like madwifi-kmp-default-r3725+AR5007EG_2.6.25.18_0.2-2.7.i586.rpm.
Install, configure card in Yast.
Let us know how it goes.