Can't install M8 and RC1 with NVidia 9600 GT

After first reboot, when the the PC enters graphic mode to finish installation, the system hangs. Nothing on screen, no mouse, no keyboard: can’t switch to console, nothing. Hard reset is the only cure. I tried to install again choosing mode 3 in inittab, but it didn’t work. Booting in safe mode doesn’t work either.
I booted from my current 11.1 system and renamed /usr/lib64/xorg in the RC1 installation. At the crucial point the install program noticed that graphics mode was not functioning and offered to finish in character mode. So it did. Later I installed the NVidia driver that worked well.
It seems that my NVidia 9600 GT is not supported by the nv driver.
Secondly, if in the first part of the installation the user chooses to boot in mode 3, the second part should be carried out in character mode. Probably the choice was made for a good reason.
System is a i7 920 with 6 GB Ram, one disk, and at installation all defaults were chosen, except for language.


The 9600 is not supported by nv yet. I booted the M8 live CD on my friends HP tower with a 9800, and it would hang. I had to boot into init 3 and change the driver to vesa, and start x from there. Hopefully the nouveau driver will be stable enough to be the default before too many more releases. It is already the default (replaced nv) in Fedora, but it is still buggy.

Thank you, I didn’t know the 9600 and higher are not supported by the nv driver. I searched the Xorg site and other sources, but I couldn’t find the info.
This is a good reason for the install program to check for the inittab setting chosen by the user before completing installation in graphics mode.
But on my laptop, with an old Ati graphics chip, that’s what the install program did: it noticed that the chip was not supported and installed in character mode (from the beginning).

This is nonsense. Check the unreviewed HOWTO’s, there’s instructions on installing the NVIDIA driver.

9600M GT works out of the box with openSUSE 11.2 RC1.
NVIDIAs own drivers work perfectly as well.

If you’re having problems, it might not be the videocard that’s to blame.

Yes, I know that the nvidia driver supports the 9600 GT,
I am using it as I write this on the same system. The problem is with the nv driver, the open source one that is used when the installed system first boots from disk after the DVD installation is finished.
But in order to install the nVidia driver, you need to use a working keyboard, monitor and a terminal. The nv driver kills the pc, so no keyboard, monitor, terminal. And this happens before installation is finished: when it stops, the home directory is empty.
By the way, this is the output of lspci | grep nVidia:
02:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)
so, it is not a 9600M GT.
Please, read the posts carefully before answering, other users could get confused.