Can't install Leap 42.3

Hi, I’m trying to install Leap on a Dell with a Nvidia gtx 960M card. The installation hangs on the loading screen with the green bar, on previous Leap versions this was solved by adding “nomodeset” on the installation parameters, but this is not the case anymore.
When I change to terminal mode, it reads:

error 37: Couldn't open file /var/adm/mount/content
loading file file:/var/adm/mount/repodata/repomd.xml -> /repomd.xml
error 37: Couldn't open file /var/adm/mount/repodata/repomd.xml
disk: mount ok but test failed
url mount: hd:/?device=disk/by-id/ata-ST1000LM014-1EJ164_W772B0E6-part2 failed

I tested my USB on another computer and installation doesn’t have any problems.

Thanks in advance.

It doesn’t complain about the USB AFAICT, but about the second partition on the HDD. That would explain why it works on the other computer.

I found that surprisingly,
Errors like what you describe can be caused by network connection problems (server side).

Is your install a NET or DVD image?
If your USB is large enough to hold a DVD image, I’ve found that the various errors relating to storage and drivers are generally avoided (they can all be provided by the DVD image and don’t need to be downloaded).

Else, in any case persistence or connecting to a different mirror can fix your problem (I used a VPN to connect to a different part of the world).

This is what I posted recently in another Forum thread which summarizes my recommendations


I have the same problem but with a different detail: Installation process hangs at 95%.

I verify the checksum and it’s ok.
I verify the medium before start installation and everything was ok.
I used this usb image to install it on my PC and it worked perfectly. However when I use this image on my laptop as a fresh copy it gets stuck at 95%. Seen details I noticed that this problem occurs when the installer is moving to the new installed system (saving configurations).

Also I noticed that Non-OSS repositories connection doesn’t work.

I summarized my Install recommendations in this post

Per one of my recommendations, there is a tendency to hang past 95% completing “Step 5” in the Initial Install Setup which you can see behind the progress bar if you click ESC.

The solution I found was if you have enough room on your install media, install using the DVD image, not the NET image… That will guarantee you success past all 6 install setup steps.

If you can’t use the DVD image, then I suggest you try connecting to a different mirror, but that would require reconfiguring your network connection (which may be difficult to do).


I used a DVD image too, and I got the same error. However I would like to prove connecting to a different mirror, can you explain how to do that?

Thanks in advance.

If you are installing on bare metal and don’t have control of your Internet Gateway or set up a router ahead of your machine, it’s not that simple.

Probably better is to determine for sure when during your install you’re experiencing your problem (I haven’t had a problem installing with my DVD image for the past 36 hrs plus). Hit ESC when you see that green progress bar so that you can see what is really displaying. You should be able to reach the screen where you set your Time Zone because up to that point everything is on your DVD and nothing comes from elsewhere.

After that,

  • If you “Configure Online Sources” then there is a big hurdle to successfully do so, but I haven’t had a problem only recently. But, this is optional. You can instead <not> “Configure Online Sources” and deal with this only after your system is fully installed.
  • You will almost certainly run into plenty of individual packages failing. But, just keep hitting “retry” and you’ll get through the install. Unlike “Configuring Online Sources” this is trivial and requires only your finger hitting “retry” until you’re done.

If you didn’t “Configure Online Sources” during your install, no big deal. Just update your system, eg

zypper up

And then, if there is anything you want to install that you didn’t during the original install, you can do so now.
Only thing you’d be missing is the ability to install something available only from online sources in your original install.


I have a similar problem. I have 42.2 installed and attempting to upgrade. I have tried using the net installer - that didn’t work, so downloaded the full dvd image and got the same. In both cases at the point at which the green bar should appear after the kernel has loaded, my monitor goes blank and the video signal ends. I have no idea what to try next.

I have been running opensuse on this box since 11.3 and never had this issue before.

Ok - selected no ACPI in kernel options and all worked ok. No idea whatsoever why this worked. :\

My install was a DVD image, then I tried to use a NET installation, this time I could actually get to the installation GUI (where you agree with the license and all), but It got stuck at System probing - Search for system files at 75%.

Then again, thanks to everyone.

I found that if needed files aren’t downloaded that various errors can be thrown depending on what the missing files are.

This suggests that the file downloads for the 6 steps install setup aren’t verified.

For this reason, I found that the DVD is a significant advantage over the NET install because the installation setup files all come from the DVD and don’t have to be downloaded. In a new install, you’re <guaranteed> to get past those kinds of errors and arrive at setting the Time Zone. On an upgrade, I don’t know where that similar milestone is. You’d think that the Upgrade should be able to probe the existing system files if it has all the files needed to do that task.


I had exactly the same issue
Existing system Leap 42.2 on HP Pavilion g4-2235 with 8Gb RAM and Samsung 750 250Gb SSD

Leap 42.3 on USB stick would not progress past green bar as described in post 1. Tried multiple times, wired/wireless/nomodeset etc. No luck

Eventually followed (somewhat nervously) instructions here:

Worked flawlessly.
Hope this helps

hi all
unfortunately i have exactly the same error.
before installation start, when the green bar is at the bottom on the screen i get this message
error 37: couldn’t open file /var/adm/mount/content
sorry if i do not copy all text from the picture i have taken from screen
if i press ESC i get a list of activity ending with loading network driver for my BCM4313 wifi card, but no error found

i try to install a 42.3 over a 42.2 with USB stick full dvd image, no network at all.
on the same pc i have installed openSuse from 12.x
with the same USB stick i have successfully installed other three pc
Any suggestion?
thank’s a lot