Can't install kernel 4.10.1 rpm's

I recently tried to use yast to install linux 4.10.1 source rpm
and got this popup message from yast:

An error occurred during repository initialization. Specified path ‘/tmp/YaST2-03249-1iSHHQ/tmp_install_repo’ is not a directory: file:/tmp/YaST2-03249-1iSHHQ/tmp_install_repo

I looked in the yast repo list. There was an entry for this directory.
The temp repo directory was apparently in /tmp, but was deleted when exited.

I had same result on the other rpm’s in the web folder.

Tried rpm -i but that didn’t work either.

Now the temporary repo entry in the yast list is gone, but the popup appears every time I run yast.

So now I have two problems:

1: Can’t install the repos. Could I pass a key to rpm to make it work?

2: Can’t make the error popup go away. I didn’t find the list in systemd config files.
Where is it stored?

Why not add the Repo and install it than?

Thanx, that worked. Doing it manually allowed me the option to accept the key in the repo, and finish my task.

However I think the fact that automatic mode (invoked by clicking on the rpm name in the web page) doesn’t is a bug.