Can't install KDE 4.2 in openSUSE 11.1

I try to install KDE 4.2 however I got this:

YaST2 conflicts list - generated 2009-06-05 13:46:51

kdebluetooth4-0.3-4.1.1.x86_64 requires solid-bluez4 >= 0.1, but this requirement cannot be provided
uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.i586[openSUSE:11.1:Update]
kdebase4-workspace-4.1.3-10.2.1.x86_64[openSUSE:11.1:Update]
kdebase4-workspace-4.1.3-10.2.1.i586[repo-update]
kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
] Following actions will be done:
do not install kdebase4-workspace-4.2.4-3.4.x86_64
do not install kde4-kcalc-4.2.4-1.4.x86_64
] install kdebluetooth4-0.3-8.7.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kdebluetooth4

kde4-kerry-0.2.90-4.6.x86_64 requires kdepimlibs4 < 4.1.60, but this requirement cannot be provided
uninstallable providers: kdepimlibs4-4.1.3-5.1.x86_64[openSUSE 11.1-0]
kdepimlibs4-4.1.3-5.1.i586[repo-oss]
kdepimlibs4-4.1.3-5.1.x86_64[repo-oss]
] Following actions will be done:
do not install kdepimlibs4-4.2.4-1.4.x86_64
do not install kde4-kdialog-4.2.4-1.4.x86_64
] install kde4-kerry-0.2.90-7.13.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-kerry

kdebase4-workspace-4.1.3-10.3.7.x86_64 requires kdebase4-workspace-ksysguardd = 4.1.3, but this requirement cannot be provided
uninstallable providers: kdebase4-workspace-ksysguardd-4.1.3-10.1.x86_64[openSUSE 11.1-0]
kdebase4-workspace-ksysguardd-4.1.3-10.2.1.i586[openSUSE:11.1:Update]
kdebase4-workspace-ksysguardd-4.1.3-10.2.1.x86_64[openSUSE:11.1:Update]
kdebase4-workspace-ksysguardd-4.1.3-10.1.i586[repo-oss]
kdebase4-workspace-ksysguardd-4.1.3-10.1.x86_64[repo-oss]
kdebase4-workspace-ksysguardd-4.1.3-10.2.1.i586[repo-update]
kdebase4-workspace-ksysguardd-4.1.3-10.2.1.x86_64[repo-update]
] install kde4-plasmoid-quickaccess-0.8-3.11.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kdebase4-workspace

 ] Following actions will be done:

do not install kdebase4-workspace-ksysguardd-4.2.4-3.4.x86_64
do not install kde4-kgpg-4.2.4-1.4.x86_64

kdebase4-session-4.2.4-3.4.x86_64 requires kdebase4-workspace >= 4.2.3, but this requirement cannot be provided
uninstallable providers: kdebase4-workspace-4.2.4-3.4.x86_64[20090605-124038]
kdebase4-workspace-4.2.4-3.4.i586[20090605-124038]
kdebase4-workspace-4.2.4-3.4.x86_64[KDE:42]
kdebase4-workspace-4.2.4-3.4.i586[KDE:42]
] install kde4-kgreeter-plugins-4.2.4-3.4.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] do not install kdebase4-session-4.2.4-3.4.x86_64

 ] Ignore some dependencies of kdebase4-session

kde4-konqueror-4.2.4-1.4.x86_64 requires kdebase4-libkonq = 4.2.4, but this requirement cannot be provided
uninstallable providers: kdebase4-libkonq-4.2.4-1.4.x86_64[20090605-124038]
kdebase4-libkonq-4.2.4-1.4.i586[20090605-124038]
kdebase4-libkonq-4.2.4-1.4.x86_64[KDE:42]
kdebase4-libkonq-4.2.4-1.4.i586[KDE:42]
] install kdebase4-libkonq-4.2.4-1.4.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] do not install kde4-konqueror-4.2.4-1.4.x86_64

 ] Ignore some dependencies of kde4-konqueror

kdenetwork4-filesharing-4.2.4-2.5.x86_64 requires kdebase4-runtime >= 4.2.4, but this requirement cannot be provided
uninstallable providers: kdebase4-runtime-4.2.4-2.4.x86_64[20090605-124038]
kdebase4-runtime-4.2.4-2.4.i586[20090605-124038]
kdebase4-runtime-4.2.4-2.4.x86_64[KDE:42]
kdebase4-runtime-4.2.4-2.4.i586[KDE:42]
] do not install kdenetwork4-filesharing-4.2.4-2.5.x86_64

 ] Ignore some dependencies of kdenetwork4-filesharing

 ] install kdebase4-runtime-4.2.4-2.4.x86_64 (with vendor change)

openSUSE

openSUSE Build Service

kde4-ksudoku-4.2.4-1.4.x86_64 requires kdegames4 >= 4.2.4, but this requirement cannot be provided
uninstallable providers: kdegames4-4.2.4-1.4.x86_64[20090605-124038]
kdegames4-4.2.4-1.4.i586[20090605-124038]
kdegames4-4.2.4-1.4.x86_64[KDE:42]
kdegames4-4.2.4-1.4.i586[KDE:42]
] install kdegames4-carddecks-default-4.2.4-1.1.noarch (with vendor change)
openSUSE

openSUSE Build Service

 ] do not install kde4-ksudoku-4.2.4-1.4.x86_64

 ] Ignore some dependencies of kde4-ksudoku

kde4-akregator-4.2.4-2.4.x86_64 requires kdepimlibs4 >= 4.2.4, but this requirement cannot be provided
uninstallable providers: kdepimlibs4-4.2.4-1.4.x86_64[20090605-124038]
kdepimlibs4-4.2.4-1.4.i586[20090605-124038]
kdepimlibs4-4.2.4-1.4.x86_64[KDE:42]
kdepimlibs4-4.2.4-1.4.i586[KDE:42]
] install kdelibs4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-akregator

 ] Following actions will be done:

do not install kde4-akregator-4.2.4-2.4.x86_64
do not install kdebase4-nsplugin-4.2.4-1.4.x86_64

enchant-1.4.2-16.55.x86_64 requires libenchant.so.1()(64bit), but this requirement cannot be provided

 ] install kdelibs4-core-4.2.4.1-2.3.x86_64 (with vendor change)

openSUSE

openSUSE Build Service

 ] Ignore some dependencies of enchant

 ] Following actions will be done:

do not install kde4-kopete-4.2.4-2.5.x86_64
do not install kde4-kmag-4.2.4-2.4.x86_64
do not install kde4-kfind-4.2.4-1.4.x86_64

libkdepimlibs4-4.1.3-5.2.6.x86_64 requires libakonadi4 = 4.1.3, but this requirement cannot be provided
uninstallable providers: libakonadi4-4.1.3-5.1.x86_64[openSUSE 11.1-0]
libakonadi4-4.1.3-5.1.i586[repo-oss]
libakonadi4-4.1.3-5.1.x86_64[repo-oss]
] do not install libakonadi4-4.2.4-1.4.x86_64

 ] Ignore some dependencies of libkdepimlibs4

kde4-kscd-4.2.4-1.4.x86_64 requires libmusicbrainz.so.4()(64bit), but this requirement cannot be provided

 ] Following actions will be done:

install libkcddb4-4.2.4-1.4.x86_64 (with vendor change)
openSUSE

openSUSE Build Service
install libkcompactdisc4-4.2.4-1.4.x86_64 (with vendor change)
openSUSE

openSUSE Build Service
] Ignore some dependencies of kde4-kscd

kde4-plasma-addons-4.2.4-1.4.x86_64 requires libplasma.so.3()(64bit), but this requirement cannot be provided
uninstallable providers: libkde4-4.2.4.1-2.3.x86_64[20090605-124038]
libkde4-4.2.4.1-2.3.x86_64[KDE:42]
] Ignore some dependencies of kde4-plasma-addons

 ] Following actions will be done:

do not install kde4-plasma-addons-4.2.4-1.4.x86_64
do not install kde4-kget-4.2.4-2.5.x86_64
] install libkde4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

kde4-kwin-4.2.4-3.4.x86_64 requires kdebase4-runtime >= 4.2.4, but this requirement cannot be provided
uninstallable providers: kdebase4-runtime-4.2.4-2.4.x86_64[20090605-124038]
kdebase4-runtime-4.2.4-2.4.i586[20090605-124038]
kdebase4-runtime-4.2.4-2.4.x86_64[KDE:42]
kdebase4-runtime-4.2.4-2.4.i586[KDE:42]
] install libkdecore4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-kwin

kde4-kreversi-4.2.4-1.4.x86_64 requires kdegames4 >= 4.2.4, but this requirement cannot be provided
uninstallable providers: kdegames4-4.2.4-1.4.x86_64[20090605-124038]
kdegames4-4.2.4-1.4.i586[20090605-124038]
kdegames4-4.2.4-1.4.x86_64[KDE:42]
kdegames4-4.2.4-1.4.i586[KDE:42]
] install libkdegames4-4.2.4-1.4.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] do not install kde4-kreversi-4.2.4-1.4.x86_64

 ] Ignore some dependencies of kde4-kreversi

Give us list of your configured repos:

zypper lr --details

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±---------------------±----------------------±--------±--------±---------±-------±--------------------------------------------------------------------------------±-------
1 | 20090605-124038 | 20090605-124038 | Yes | Yes | 100 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
2 | ATI Repository | ATI Repository | Yes | Yes | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
3 | KDE:42 | KDE:42 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
4 | Packman | Packman | Yes | Yes | 99 | rpm-md | Index of /Linux/Packman/suse/11.1 |
5 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
6 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
7 | openSUSE:11.1:Update | openSUSE:11.1:Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
8 | repo-debug | openSUSE-11.1-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.1/repo/oss |
9 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
10 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/oss |
11 | repo-source | openSUSE-11.1-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.1/repo/oss |
12 | repo-update | openSUSE-11.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1

First change the priority in the repo #1 (kde 42) to 99 to match all the others, oss and non-oss should be 120, refresh them all and try again. Check my guide

KDE4.2.* (How To Add) Guide. - openSUSE Forums

the key if there are errors is to allow change to Build Service
eg:

] install kdebluetooth4-0.3-8.7.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

I did what you say, but it still doesn’t work. I’ve given up, I wonder what does the “one click install” means. It doesn’t bring me any easy thing.

Given Up!
‘Doesn’t work’! - HOW?

As for OneClick, it looks to me like you have already been at it. Looking again at your repo list, you can delete repo #1 because it’s a duplicate of #3

Do that.
Post your repo list again

zypper lr --details

Then post your problem when trying the upgrade.

Your repositories need tidying up. As mentioned by caf4926, the priority numbers need adjusting. You also have duplications: 1 and 3, 7 and 12. You’ll need to do the commands from terminal as root (use su command).

So you could safely delete 1 and 7 with

zypper rr 1
zypper rr 7

Adjust oss and non-oss repo priorities:

zypper mr --priority 120 9
zypper mr --priority 120 10

Try updating with

zypper up

Thanks for both of you. I did what you said. Unfortunately, it still doesn’t work. Here are my repository list and error report.

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±---------------------±----------------------±--------±--------±---------±-------±--------------------------------------------------------------------------------±-------
1 | ATI Repository | ATI Repository | Yes | Yes | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
2 | KDE:42 | KDE:42 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
3 | Packman | Packman | Yes | Yes | 99 | rpm-md | Index of /Linux/Packman/suse/11.1 |
4 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
5 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
6 | repo-debug | openSUSE-11.1-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.1/repo/oss |
7 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
8 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/oss |
9 | repo-source | openSUSE-11.1-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.1/repo/oss |
10 | repo-update | openSUSE-11.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |

YaST2 conflicts list - generated 2009-06-05 21:09:50

kde4-kate-4.2.4-1.4.x86_64 requires libplasma.so.3()(64bit), but this requirement cannot be provided
uninstallable providers: libkde4-4.2.4.1-2.3.x86_64[KDE:42]
] Following actions will be done:
do not install kde4-kate-4.2.4-1.4.x86_64
do not install kde4-kcalc-4.2.4-1.4.x86_64
do not install kde4-kdialog-4.2.4-1.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
] install libkde4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-kate

kdebluetooth4-0.3-4.1.1.x86_64 requires solid-bluez4 >= 0.1, but this requirement cannot be provided
uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.i586[repo-update]
kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
] Following actions will be done:
do not install kdebase4-workspace-4.2.4-3.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
] install kdebluetooth4-0.3-8.7.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kdebluetooth4

kde4-kerry-0.2.90-4.6.x86_64 requires kdepimlibs4 < 4.1.60, but this requirement cannot be provided
uninstallable providers: kdepimlibs4-4.1.3-5.1.x86_64[openSUSE 11.1-0]
kdepimlibs4-4.1.3-5.1.i586[repo-oss]
kdepimlibs4-4.1.3-5.1.x86_64[repo-oss]
] Following actions will be done:
do not install kdepimlibs4-4.2.4-1.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
] install kde4-kerry-0.2.90-7.13.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-kerry

kdelibs4-4.1.3-4.10.4.x86_64 requires libkde4 = 4.1.3, but this requirement cannot be provided
uninstallable providers: libkde4-4.1.3-4.9.x86_64[openSUSE 11.1-0]
libkde4-4.1.3-4.9.i586[repo-oss]
libkde4-4.1.3-4.9.x86_64[repo-oss]
] Following actions will be done:
do not install kde4-kget-4.2.4-2.5.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdialog-4.2.4-1.4.x86_64
] install kdelibs4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kdelibs4

-----AND MORE-----

YaST2 conflicts list - generated 2009-06-05 21:09:50

kde4-kate-4.2.4-1.4.x86_64 requires libplasma.so.3()(64bit), but this requirement cannot be provided
uninstallable providers: libkde4-4.2.4.1-2.3.x86_64[KDE:42]
] Following actions will be done:
do not install kde4-kate-4.2.4-1.4.x86_64
do not install kde4-kcalc-4.2.4-1.4.x86_64
do not install kde4-kdialog-4.2.4-1.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
** X] install libkde4-4.2.4.1-2.3.x86_64 (with vendor change)**
openSUSE

openSUSE Build Service

 ] Ignore some dependencies of kde4-kate

kdebluetooth4-0.3-4.1.1.x86_64 requires solid-bluez4 >= 0.1, but this requirement cannot be provided
uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.i586[repo-update]
kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
] Following actions will be done:
do not install kdebase4-workspace-4.2.4-3.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
** X] install kdebluetooth4-0.3-8.7.x86_64 (with vendor change)
openSUSE**

openSUSE Build Service

 ] Ignore some dependencies of kdebluetooth4

kde4-kerry-0.2.90-4.6.x86_64 requires kdepimlibs4 < 4.1.60, but this requirement cannot be provided
uninstallable providers: kdepimlibs4-4.1.3-5.1.x86_64[openSUSE 11.1-0]
kdepimlibs4-4.1.3-5.1.i586[repo-oss]
kdepimlibs4-4.1.3-5.1.x86_64[repo-oss]
] Following actions will be done:
do not install kdepimlibs4-4.2.4-1.4.x86_64
do not install kde4-kdepasswd-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
** X] install kde4-kerry-0.2.90-7.13.x86_64 (with vendor change)
openSUSE

openSUSE Build Service
**
] Ignore some dependencies of kde4-kerry

kdelibs4-4.1.3-4.10.4.x86_64 requires libkde4 = 4.1.3, but this requirement cannot be provided
uninstallable providers: libkde4-4.1.3-4.9.x86_64[openSUSE 11.1-0]
libkde4-4.1.3-4.9.i586[repo-oss]
libkde4-4.1.3-4.9.x86_64[repo-oss]
] Following actions will be done:
do not install kde4-kget-4.2.4-2.5.x86_64
do not install kde4-ark-4.2.4-1.4.x86_64
do not install kde4-kdf-4.2.4-1.4.x86_64
do not install kde4-kfloppy-4.2.4-1.4.x86_64
do not install kde4-kdialog-4.2.4-1.4.x86_64
** X] install kdelibs4-4.2.4.1-2.3.x86_64 (with vendor change)
openSUSE

openSUSE Build **Service

 ] Ignore some dependencies of kdelibs4

-----AND MORE-----

OK, caf4926 , you’re so kind. However, my problem still can’t be solved. I tried what you said, then I clicked the “OK Try again” Button. Nothing happens. In other words, I can’t go on any further. The system still told me there are a lot of conflicts. Well, I think it’s better for me to use the KDE 4.1 at present.

You give up too easy. Post the error. We can sort it.

i am having the same problem and have tired all that was suggested in this thread. The kdebase4-runtime always comes up in the list of packages in the Yast installer as 4.1.3, i.e. 4.1.3-4.2.9, with no newer version indicated as installable, though i see 4.2.4 for other packages, e.g. for kdebase4-session i have an installed version of 4.1.3-2.2, but an available version of 4.2.4-3.4.

I suspect that a file is not have the proper specification for kdebase4-runtime in the Index of /repositories/KDE:/42/openSUSE_11.1 repository, but i do know enough about the correct format to be able to say with certainty.

The output from ‘zypper lr --details’ is:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±----------------±----------------------±--------±--------±---------±-------±-------------------------------------------------------------------------------------±-------
1 | KDE3 | KDE3 | Yes | Yes | 50 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
2 | KDE3-Base | KDE3-Base | Yes | Yes | 50 | rpm-md | Index of /repositories/KDE:/KDE3/openSUSE_11.1 |
3 | KDE4-Community | KDE4-Community | Yes | Yes | 50 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42 |
4 | KDE4.2-Base | KDE4.2-Base | Yes | Yes | 50 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
5 | NVidia | NVidia | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1/ |
6 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
7 | repo-debug | openSUSE-11.1-Debug | Yes | No | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
8 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
9 | repo-oss | openSUSE-11.1-Oss | Yes | No | 100 | yast2 | Index of /distribution/11.1/repo/oss |
10 | repo-source | openSUSE-11.1-Source | Yes | No | 99 | yast2 | Index of /source/distribution/11.1/repo/oss |
11 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |

But i seriously doubt that the repository specification is relevant. I think that the repository files need to be rebuilt.

But i seriously doubt that the repository specification is relevant
Wrong!

The spec is very important and you have it wrong. Change the priority of Updates to 50 to match the kde repos.

Now try.