Can't install GRUB

Hi there.
I try to install SuSe but can’t get further than trying to install GRUB, then I get the following error:

GNU GRUB version 0.97 (640 lower/3072 uppermemory)
[Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. ANywhere else TAB lists the possible completions of device/filename.]
grub>setup --stage 2=/boot/grub/stage2 --force-lba (hd0.2)(hd0.5)
Checking if “/boot/grub/stage1” exist… yes
Checking if “/boot/grub/stage2” exist… yes
Checking if “/boot/grub/e2fs_stage5” exist… yes
Running “embed /boot/grub/e2fs_stage5 (hd0,2)”… failed (this is not fatal)
Running “embed /boot/grub/e2fs_stage5 (hd0,5)”… failed (this is not fatal)
Running “install --force-lba --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,2) /boot/grub/stage2 p /boot/grub/menu.lst”… failed

Error 22: No such partition
grub> quit

Please, can anyone help?
A newbie

it seems that the partition you are saying is root does not exist

Do you have any idea how to solve the problem?

what is the output of fdisk -l? What was your intent on making partitions? Do you have a separate /boot?

If this is a new installation, then at the Installation summary click Booting. Click the tab Boot Loader Installation. Put a check only next to Boot from Master Boot Record.

Try that and see what it does.

Hope this helps!


¿Have you tried LILO?

For some reason, grub from OS11, OS11.1 & SLED11 won’t work on my system and lilo never functioned because it is unsupported for these versions.

I had to downgrade (yet it was an upgrade for me) from these newer versions to OS10.3 with LILO, and it worked (didn’t bother trying to install grub because i was positive that LILO for 10.3 would work flawlessly as it did with SLED10).

Now i am happily exploring OS10.3 (i upgraded from SLED10) and have liked it very much, dual-booting nicely with xp for gaming.


YES!! Installation succeded!!!
Thank you - thank you - thank you…
It worked with Ians solution and Ian, thank you for writing in a language that even a nevbie understand :wink:
OF - I didn’t get to try your solution, but thanks to you as well - I’m happy to have joined this forum.


Glad to see you’re up and running!

Welcome to openSUSE!