Can't install from non-OSS CD


I downloaded openSuSE 11.1 and burned a DVD and a CD with the non-OSS packages.
I first installed only a standard set of packages. When this went well, i.e. after I could boot succesfully, I installed more packages. yast tried to download them from some server and failed. So I changed the software repositories to only use my CD and DVD.
All went well until I tried to install Acroread. It told me that it needs several libraries it can’t find. I couldn’t install any of the other non-OSS packages either.

Any hints appreciated.

Thanks, Stephan

Show us your list of repos:

zypper lr -d

I disabled everything but the first two. Is that the problem?

1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
2 | openSUSE-11.1-Non-Oss | openSUSE-11.1-Non-Oss | Yes | Yes | 99 | yast2 | cd:///?devices=/dev/sr0 |
3 | repo-debug | openSUSE-11.1-Debug | No | No | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
4 | repo-oss | openSUSE-11.1-Oss | No | No | 100 | yast2 | Index of /distribution/11.1/repo/oss |
5 | repo-source | openSUSE-11.1-Source | No | No | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
6 | repo-update | openSUSE-11.1-Update | No | No | 100 | rpm-md | Index of /update/11.1 |

Well, I wouldn’t disable the update repo for one thing.

I see no reason to disable the online repos, unless you have a very small Internet plan. I installed acroread and it just worked. It might have fetched some dependencies from online repos, I didn’t pay attention. Perhaps there is a way with zypper to check which repos the dependencies of a package come from, it is not obvious from the man page.

I am having the same issue; did you ever get it resolved? I am a novice at Linux, so please be very detailed.

Thanks in advance.

On 07/21/2011 07:46 AM, 50asm wrote:

> I am having the same issue; did you ever get it resolved? I am a novice
> at Linux, so please be very detailed.

-=welcome=- new poster…

you have inadvertently responded to an over two year old post dealing
with a no longer supported version of openSUSE, and say you have the
same issue…

if you have an issue with openSUSE 11.1 you need to start over, and
fetch a supported version here

but, as a novice (welcome again) you will benefit from the much of the
info, and all of the reading list i gave another yesterday, here:

openSUSE®, the “German Engineered Automobiles” of operating systems!