can't install drivers for Netgear WG311v3

OK I’m new to OpenSUSE and I’m having trouble installing my wireless card drivers. I’ve read a lot on this using Ndiswrapper to install my drivers but when I go to install I get this.

**linux-8h6g:/wg311 # ndiswrapper -i wg311v3.inf
couldn’t open wg311v3.inf: No such file or directory at /usr/sbin/ndiswrapper line 219.

I’m giving the right path to the inf file tried moving to other folders and still nothing.

Thanks in advance for your help.

Hi jmac4065. Welcome to the forums!

Are you sure you’ve got the file name right? Linux file names are case sensitive. For example, it might be ‘wg311v3.INF’, or WG311v3.INF…

(Its difficult for me to tell, because you didn’t list the directory containing the driver files).

well that was it the file name. I got the drivers installed.

**linux-8h6g:/home/jeff # ndiswrapper -l
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
wg311v3 : driver installed
device (11AB:1FAA) present

Now where from here?

I haven’t had to use ndiswrapper for a long time. (Its the last resort with network cards and can cause problems with the kernel depending on windows driver loaded). Anyway, I suggest you now read this guide

SDB:Ndiswrapper - openSUSE

You can start at the section ‘Configuring your card in YaST’.

Make sure you have the ndiswrapper module loaded. Check with

lsmod |grep ndiswrapper

If not, load it manually (as root)

modprobe ndiswrapper

Then configure as per the instructions in the guide.

This thread may be ueful too:

newbies and ndiswrapper

Maybe it helps you (or other users with a problem alike):
Your chip-set (numeric pci-id: 11ab:1faa ) seems to be from Marvell

List of PCI ID’s

Version: 2011.01.22

Date: 2011-01-22 03:15:03

Maintained by Martin Mares <> and other volunteers from the

PCI ID Project at

New data are always welcome, especially if they are accurate. If you have

anything to contribute, please follow the instructions at the web site.

This file can be distributed under either the GNU General Public License

(version 2 or higher) or the 3-clause BSD License.

pci_ids 11ab ‘Marvell Technology Group Ltd.’
pci_ids 11ab 1faa ‘88w8335 [Libertas] 802.11b/g Wireless’
pci_ids 11ab 1faa 1385 4e00 ‘WG511v2 54 Mbps Wireless PC Card’
pci_ids 11ab 1faa 1385 6b00 ‘WG311v3 802.11g Wireless PCI Adapter’
pci_ids 11ab 1faa 1737 0040 ‘WPC54G v5 802.11g Wireless-G Notebook Adapter’



Alright here is the latest I got my wireless card to configure in YaST and when it completes I get this

**88w8335 [Libertas] 802.11b/g Wireless (Not connected)
MAC : 00:22:3f:f5:2d:07
BusID : 0000:02:0d.0

Device Name: wlan0
Started automatically at boot
IP address assigned using DHCP

I can’t get it to connect.

Have you read the Wireless Forum stickies?


Are you using a different wireless device now? If so, I would start another thread, with a descriptive title, and the info provided as described in the stickies.

still the same wireless card, just trying to learn this stuff. I’ll work and research more thanks

Set yast > network devices > network settings to use ‘User controlled with Network Manager’ (Global Options), then you can use network manager to configure/control your wireless device.

When I did this it still would not connect. I see my network when I scan for it and I put in my password still won’t connect.

Here is the info I gathered when I read the sticky on how to setup my network.

Cell 01 - Address: 00:1E:E5:77:46:C9
ESSID:“Ship Happens”
Protocol:IEEE 802.11g
Frequency:2.462 GHz (Channel 11)
Quality:51/100 Signal level:-63 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK

lo no wireless extensions.

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:1 Mb/s Sensitivity=-200 dBm
RTS thr=2346 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

11.244130] ndiswrapper version 1.55 loaded (smp=yes, preempt=yes)
11.334079] ndiswrapper: driver wg311v3 (NETGEAR,02/22/2005, loaded
11.334769] alloc irq_desc for 18 on node -1
11.334779] alloc kstat_irqs on node -1
11.334803] ndiswrapper 0000:02:0d.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
11.342718] ndiswrapper: using IRQ 18
11.597134] wlan0: ethernet device 00:22:3f:f5:2d:07 using NDIS driver: wg311v3, version: 0x3000036, NDIS version: 0x501, vendor: ‘NDIS Network Adapter’, 11AB:1FAA.5.conf
11.597176] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
11.599174] usbcore: registered new interface driver ndiswrapper
11.782408] Adding 576508k swap on /dev/sdb5. Priority:-1 extents:1 across:576508k
12.680165] device-mapper: uevent: version 1.0.3
12.683326] device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised:
13.255437] loop: module loaded
13.563901] EXT4-fs (sdb7): mounted filesystem with ordered data mode


Have you got kwallet up and running (if using KDE4)? AFAIU, it is required to handle the encrypted passwords for network manager. If using Gnome, its the Gnome keyring…

wireless 3945ABG won`t work

Do I need to use Kwallet for wireless encryption key to work in openSUSE11.3 KDE?