Can't install Bootloader/Device not Found

I recently got a new 2TB SSD and imaged my old one onto it. I had it set to dual boot with Windows 10 using Grub. When I plugged the new drive in I would get an error saying “filesystem not found” and a rescue console. Using the old drive I was able to restore the Windows bootloader and boot to Windows. Now I’m trying to get back to the Linux bootloader so I can dual boot again. I downloaded the latest install disk for 15.6 Leap(The original system was at 15.3) and created a USB Installer for it. When I booted from the install disk I selected the ‘Boot to Linux’ option and was able to log into my Linux partition.

However, this is where things went south. I tried to install the Bootloader through Yast2 and got the following message:

Probing file system with UUID XXXXXXXXX failed
Unexpected situation found in the system.
Click below to see more details (English only).
Continue despite the issue?

When I click to see more details:

device not found, name:/dev/sda4

If I click to Continue:

YaST cannot configure the bootloader because it failed to find the root file system.

The same error occurs if i open up Partitioning, but if I open up the Disks application, it shows all the partitions on the drive. Clearly /dev/sda4 DOES exist as it is the partition that Linux is running from.

Searching the forums I did find another thread with the same issue which referenced the following bug report:
https://bugzilla.suse.com/show_bug.cgi?id=1179061#c12

I tried the fix listed in there, invoking “LIBSTORAGE_BTRFS_SNAPSHOT_RELATIONS=no yast2 bootloader” but that still had the same result.

I tried to upgrade the system using the installer USB, but had the same issue. After setting up all the configuration options it gave me the same device not found error, so I booted back into the system and did the install in place using zypper. Everything seems to have gone alright there and it looks like I am now running 15.6 Leap. I still have to use the USB to boot into the system though.

Aside from getting rid of the current Linux install and reinstalling from scratch, does anyone have any ideas of what I can do to fix it?

What exactly does it mean?

Output of

cat /etc/fstab
findmnt --real -u -o +uuid,partuuid
fdisk -l
lsblk -f -o +partuuid
efibootmgr -v
cat /etc/default/grub_installdevice

could be interesting. As preformatted text or uploaded to https://paste.opensuse.org/

I used a disc copying program (in this case Arconis) to create an exact image of the original hard drive which was then copied onto this one. I’ve done it many times before with Linux/Windows dual boot drives and never had an issue previously

Output of
cat /etc/fstab

UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /                       btrfs  defaults                      0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /var                    btrfs  subvol=/@/var                 0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /root                   btrfs  subvol=/@/root                0  0
UUID=1cbff943-a2d5-4ac0-b67e-e345dfc9e678  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=9fe8425c-e2b9-4990-a602-dc989a0c2630  /home                   xfs    defaults                      0  0
UUID=4b3ef1f7-6f11-4d37-9d58-c002c3a10e41  swap                    swap   defaults                      0  0

findmnt --real -u -o +uuid,partuuid

TARGET SOURCE FSTYPE      OPTIONS                                                                                                                                                UUID                                 PARTUUID
/      /dev/sda4[/@/.snapshots/1/snapshot]
              btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=266,subvol=/@/.snapshots/1/snapshot                                                                 1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/srv /dev/sda4[/@/srv]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=260,subvol=/@/srv                                                                                   1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/boot/grub2/x86_64-efi
│      /dev/sda4[/@/boot/grub2/x86_64-efi]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=263,subvol=/@/boot/grub2/x86_64-efi                                                                 1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/tmp /dev/sda4[/@/tmp]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=259,subvol=/@/tmp                                                                                   1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/opt /dev/sda4[/@/opt]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=262,subvol=/@/opt                                                                                   1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/root
│      /dev/sda4[/@/root]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=261,subvol=/@/root                                                                                  1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/boot/grub2/i386-pc
│      /dev/sda4[/@/boot/grub2/i386-pc]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=264,subvol=/@/boot/grub2/i386-pc                                                                    1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/var /dev/sda4[/@/var]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=257,subvol=/@/var                                                                                   1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/usr/local
│      /dev/sda4[/@/usr/local]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=258,subvol=/@/usr/local                                                                             1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/.snapshots
│      /dev/sda4[/@/.snapshots]
│             btrfs       rw,relatime,ssd,discard=async,space_cache,subvolid=265,subvol=/@/.snapshots                                                                            1cbff943-a2d5-4ac0-b67e-e345dfc9e678 5037e009-04
├─/run/user/1000/doc
│      portal fuse.portal rw,nosuid,nodev,relatime,user_id=1000,group_id=100                                                                                                                                          
├─/run/user/0/doc
│      portal fuse.portal rw,nosuid,nodev,relatime,user_id=0,group_id=0                                                                                                                                               
├─/run/media/jsmith/openSUSE-Leap-15.6-DVD-x86_64710
│      /dev/sdb2
│             iso9660     ro,nosuid,nodev,relatime,nojoliet,check=s,map=n,blocksize=2048,uid=1000,gid=100,dmode=500,fmode=400,iocharset=utf8                                     2024-06-20-11-53-50-15               4568d8e4-02
├─/run/media/jsmith/DATA
│      /dev/sdc1
│             vfat        rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro 8029-180D                            0002ae3f-01
└─/home
       /dev/sda5
              xfs         rw,relatime,attr2,inode64,logbufs=8,logbsize=32k,noquota                                                                                               9fe8425c-e2b9-4990-a602-dc989a0c2630 5037e009-05

fdisk -l

Disk /dev/sda: 1.86 TiB, 2048408248320 bytes, 4000797360 sectors
Disk model: T-FORCE T253TY00
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x5037e009

Device     Boot      Start        End    Sectors  Size Id Type
/dev/sda1  *          2048 3838044159 3838042112  1.8T  7 HPFS/NTFS/exFAT
/dev/sda2       3999528960 4000796671    1267712  619M 27 Hidden NTFS WinRE
/dev/sda3       3911446528 3999528960   88082433   42G  5 Extended
/dev/sda4       3838044160 3911446527   73402368   35G 83 Linux
/dev/sda5       3911448576 3995334655   83886080   40G 83 Linux
/dev/sda6       3995336704 3999528959    4192256    2G 82 Linux swap / Solaris

Partition table entries are not in disk order.


Disk /dev/sdb: 7.27 GiB, 7801405440 bytes, 15237120 sectors
Disk model: Storage Media   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4568d8e4

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1        4240   13059    8820  4.3M ef EFI (FAT-12/16/32)
/dev/sdb2  *    13060 9046015 9032956  4.3G 17 Hidden HPFS/NTFS


Disk /dev/sdc: 930.86 GiB, 999501594624 bytes, 1952151552 sectors
Disk model: My Book 1110    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0002ae3f

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdc1  *     2048 1952151551 1952149504 930.9G  b W95 FAT32

lsblk -f -o +partuuid

NAME FSTYPE FSVER LABEL                            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS PARTUUID
sda                                                                                                                
├─sda1
│    ntfs                                          C4965D3A9C5A3D57                                                5037e009-01
├─sda2
│    ntfs                                          AD91F0A2505152FB                                                5037e009-02
├─sda3
│                                                                                                                  5037e009-03
├─sda4
│    btrfs                                         1cbff943-a2d5-4ac0-b67e-e345dfc9e678    4.2G    87% /opt        5037e009-04
│                                                                                                      /root       
│                                                                                                      /tmp        
│                                                                                                      /boot/grub2/i386-pc 
│                                                                                                      /usr/local  
│                                                                                                      /var        
│                                                                                                      /srv        
│                                                                                                      /.snapshots 
│                                                                                                      /boot/grub2/x86_64-efi 
│                                                                                                      /           
├─sda5
│    xfs                                           9fe8425c-e2b9-4990-a602-dc989a0c2630   28.4G    29% /home       5037e009-05
└─sda6
     swap   1                                      9123e8c3-051d-ba8d-e63d-92892610834d                            5037e009-06
sdb  iso966 Jolie openSUSE-Leap-15.6-DVD-x86_64710 2024-06-20-11-53-53-97                                          
├─sdb1
│    vfat   FAT16 openSUSE-Leap-15.6-DVD-x86_64710 5A00-902D                                                       4568d8e4-01
└─sdb2
     iso966 Jolie openSUSE-Leap-15.6-DVD-x86_64710 2024-06-20-11-53-50-15                     0   100% /run/media/jsmith/openSUSE-Leap-15.6-DVD-x86_64710
                                                                                                                   4568d8e4-02
sdc                                                                                                                
└─sdc1
     vfat   FAT32 DATA                             8029-180D                               273G    71% /run/media/jsmith/DATA
                                                                                                                   0002ae3f-01
sr0  udf    1.50  WD SmartWare                     4ad6477500000000

efibootmgr -v

BootCurrent: 000D
Timeout: 0 seconds
BootOrder: 000D,0011,000E,000B,000C,0013,0012,0000,0001,0002,0003,0004,0005,0006,0007,0008,0009,000F,000A,0010
Boot0000  Startup Menu  FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)....ISPH
Boot0001  System Information    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0002  Bios Setup    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0003  3rd Party Option ROM Management       FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0004  System Diagnostics    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0005  System Diagnostics    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0006  System Diagnostics    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0007  System Diagnostics    FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0008  Boot Menu     FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0009  HP Recovery   FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot000A  Western Digital My Book 1110 574341563533313336373539 PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)/USB(2,0)/Unit(1)N.....YM....R,Y.....ISPH
Boot000B* T-FORCE T253TY002T :  BBS(HD,T-FORCE T253TY002T : ,0x400)/PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,0,0)......ISPH
Boot000C* Intel Corporation: IBA CL Slot 00FE v0106     BBS(Network,Intel Corporation: IBA CL Slot 00FE v0106,0x0)/PciRoot(0x0)/Pci(0x1f,0x6)......ISPH
Boot000D* Sony Storage Media 9B3001405270011302 PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)N.....YM....R,Y.....ISPH
Boot000E* Western Digital My Book 1110 574341563533313336373539:        BBS(CDROM,Western Digital My Book 1110 574341563533313336373539: ,0x500)/PciRoot(0x0)/Pci(0x14,0x0)......ISPH
Boot000F  Network Boot  FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(9d8243e8-8381-453d-aceb-c350ee7757ca)......ISPH
Boot0010  Western Digital My Book 1110 574341563533313336373539 PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)/USB(2,0)/Unit(0)N.....YM....R,Y.....ISPH
Boot0011* T-FORCE T253TY002T    PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,0,0)N.....YM....R,Y.....ISPH
Boot0012  Sony Storage Media 9B3001405270011302:        BBS(HD,Sony Storage Media 9B3001405270011302: ,0x900)/PciRoot(0x0)/Pci(0x14,0x0)......ISPH
Boot0013  Western Digital My Book 1110 574341563533313336373539:        BBS(HD,Western Digital My Book 1110 574341563533313336373539: ,0x900)/PciRoot(0x0)/Pci(0x14,0x0)......ISPH

cat /etc/default/grub_installdevice

/dev/disk/by-id/ata-HP_SSD_S700_500GB_HBSA39070100859

Your /etc/fstab does not have entry for /boot/efi which implies that your system has been setup to boot in legacy BIOS mode. When you boot from USB you need to select legacy boot (CSM or whatever it is called in your BIOS).

This refers to your old drive. When you call YaST Bootloader it should suggest to reinitialize bootloader configuration. Does it?

Also check for such /dev/disk/by-id/... references in /etc/default/grub (could be setup for resume device). Or just show this file:

grep -Ev '^$|^#' /etc/default/grub

I selected Legacy boot for the USB, and still have the same issue.

grep -Ev ‘^$|^#’ /etc/default/grub:

GRUB_DISTRIBUTOR=
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=8
GRUB_CMDLINE_LINUX_DEFAULT="splash=silent mitigations=auto quiet"
GRUB_CMDLINE_LINUX=""
GRUB_TERMINAL="gfxterm"
GRUB_GFXMODE="auto"
GRUB_BACKGROUND=
GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
SUSE_BTRFS_SNAPSHOT_BOOTING="true"
GRUB_DISABLE_OS_PROBER="false"
GRUB_ENABLE_CRYPTODISK="n"
GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"

No, when I call the bootloader program through Yast/Yast2 it stops after “Loading bootloader settings” and gives me the error above about missing sda4.

Bit of an update.

Using “update-bootloader” I was able to restore the bootloader so I don’t have to use the USB Installer to load into Linux anymore. The Grub bootloader is back and I can pick between OpenSuse and Windows with no issues.

However the dev/sda4 not being found issue is still persisting. I cannot load the bootloader module from Yast or Yast2, or open the Partitioner module. In both cases the error persists.

Clearly this is due to the reference to the old drive, but how do we fix that?

TIA