Can't install any software

Hello community!

I installed openSUSE yesterday and all works fine so far.

I’ve tried installing some software using YaST2 and this worked too
until this morning: Neither packages I chose in YaST itself nor the
security packages found by the kupdateapplet can be installed.

For example: Yesterday I successfully installed csmash (a game). But
since I didn’t like it, I removed it. If I try to install it now, I get
this in YaST:

> Subprocess failed. Error: RPM fehlgeschlagen: rpmdb: page 299: illegal
> page type or format
> rpmdb: PANIC: Invalid argument
> error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal
> error, run database recovery
> error: error(-30977) getting “Bnormal-hip01.dat” records from Basenames
> index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bnormal-racket.affine” records from
> Basenames index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bnormal-racket01.dat” records from
> Basenames index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bpeck” records from Basenames index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bpeck-Larm.affine” records from Basenames
> index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bpeck-Larm01.dat” records from Basenames
> index
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error,
> run database recovery
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30977) from db->get: DB_RUNRECOVERY: Fatal error, run
> database recovery
> error: error(-30977) getting “Bpeck-Lelbow.affine” records from
> Basenames index
> rpmdb: PANIC: fatal region error detected; run recovery
[The original message is much larger…]

I hope this is a known problem?


codester

codester’s Profile: http://forums.opensuse.org/member.php?userid=21937
View this thread: http://forums.opensuse.org/showthread.php?t=407191

open a terminal - go su then do

sudo rpmdb --rebuilddb

zypper ref

zypper up

After that try Yast


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“88.4” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=407191

Thanks, seems to work.


codester

codester’s Profile: http://forums.opensuse.org/member.php?userid=21937
View this thread: http://forums.opensuse.org/showthread.php?t=407191

codester;1940706 Wrote:
> Thanks, seems to work.

Lets hope so:|


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“88.4” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=407191