can't install amsn, suse dont't install tcl scripting langua

Hi all

i recently installed opensuse 11.1 i586, and i need to install amsn here, but i got a error when installing, it says that needs the TCL Scripting Language, i typed “tcl” on yast and i found the files needed, i check the files on software management, and i click accept, it asks for the opensuse cd, but i only have the dvd install, i put it on the dvd rom, but i get a error message “failed to mount /dev/srO …” :frowning: i dont understand whats going on.

EDIT: I think i posted in the wrong section, sorry i didnt find any other that matchs my problem

PS: sorry for my english

You need to add some repos.
amsn is in the packman repo
Have a read here Add Package Repositories to YaST - openSUSE
Or if you want to do it the easy way you can get amsn here with the one-click


I got this error with the “one click install”
"Error: IO:Failed to provide Package tls-1.6-5.43. Do you want to retry retrieval?

[openSUSE 11.1-0|cd:///?devices=/dev/sr0,/dev/sr1] Can’t provide file ‘./suse/i586/tls-1.6-5.43.i586.rpm’ from repository ‘openSUSE 11.1-0’

  • Cannot eject any media

  • Can’t provide ./suse/i586/tls-1.6-5.43.i586.rpm : Can’t eject any media"
    i tried with the opensuse dvd but i still got this error
    thanks geoffro

Strange, normally inserting the DVD satisfies the installer. Disable the DVD “repo” in YaST and subscribe to the OpenSUSE OSS repo, which is the online version of the same thing. Then try again to install tcl.

well i think i disabled the dvd, suse already have the oss repo(i think its by default), i tried again installing the tcl via yast and still getting a error
“Failed to mount cd:///?devices=/dev/sr0,/dev/sr1 on : Mounting media failed”

i burned opensuse to a dvd+rw, but there is no way to me acces the dvd here on suse.

Sorry posting again there is no EDIT button over here

i finally could disable the dvd repo, and tcl installed successfully and amsn started.

Thanks ken_yap and geoffro.:slight_smile: