Can't install 11.2 on Nvidia Raid

I can’t install 11.2 on my Nvidia raid. x2 150GB WD Raptors. Installation starts but only gets to 1%.

I get

linux udevd[126]: worker [4496] failed while handling ‘/devices/virtual/block/dm-0’

linux udevd[126]: worker [4498] unexpectedly returned with status 0x0100

and eventually

device-mapper: ioctl: unable to remove open device nvidia_eeebfafb_part3

OpenSuse 11.1 installs/runs fine on this setup…

Hope someone can help/shed light on this.

Same here, interestingly enough retrying works, but then I get hit by a bug - see my posting “11.2 install on hw raid1 with lvm2 fails”

How do I make it restart? I’ve tried various partition layouts LVM or not with EXT4 but either way I get the same problem.

There’s bug out on 11.2 for RAID installation, and I’m not sure about Nvidia “Fake RAID” driver, those are liable to leave you with an undocumented & troublesome disk format, with a rarely deployed driver under Linux.

For this I would advise using Linux RAID tools. Just partition your disk more than you would normally.

Make on one disk :

/boot - ext2 sda1 80 MB
/ - ext4 sda5
/home - ext4 …

On the other disk, duplicate partition sheme for anything you may want to mirror.

Once you’ve installed you can change data filesystems to md(4) mirror devices, with just one physical partition in mirror at first, then add partition from 2nd disk to install the mirroring.

By seperating out /boot, you can mirror that to simply, and have fall back GRUB entries in /boot/grub/menu.lst to boot from either disk.

Finally, Switch to mirroring ‘/’ and testing that. It’ll need changes to the initrd’s used, so the loaded kernel can load modules for mirrored device when it mounts the root filesystem.

Thanks for the response, I’m actually using a STRIPE array with Windoze installed on the 1st partition and then Linux installed to the other…

Ubuntu and OpenSuse 11.1 have both worked in this setup.
I guess I’m probably best removing the RAID array and using the harddrives separately…